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Introduction 
The Human Resources module in RFMS may be used to process pay for hourly, salaried, commissioned & 

subcontractor type workers.  Today we will cover the following topics:        

     

➢ Human Resources 

o Key Worker Set up items & new features 

▪ Worker Designations & Pay Types 

▪ Leave Accrual 

▪ Personal Deductions 

o Post Providers Earnings  

o Preparing Payroll for Employees & Subcontractors 

o Reports 

 

➢ Provider Matrix & Certified Payroll 

o System Options 

o Basic Set up & use 

Prerequisites 
➢ Human Resources set up 

o https://rfmsinc.zendesk.com/hc/en-us/articles/201802086-Human-Resources-User-Guide  

 

➢ Workers set up in RFMS Human Resources 

 

➢ Service Products built with costs 

 

➢ Provider Matrix & Certified Payroll activated 
o https://rfmsinc.zendesk.com/hc/en-us/articles/201892066-Provider-Rate-Matrix-User-Guide 
o https://rfmsinc.zendesk.com/hc/en-us/articles/201638996-Certified-Payroll  

o These programs are free but do require training to activate the program 

Human Resources Key Worker Set up Items & New Features 
If you are not currently using our HR program, you may wish to contact our training department for assistance 

in setting up your system.  I’ve also provided links throughout this documents to our Zendesk for additional 

reference information.   

mailto:jking@rfms.com
https://rfmsinc.zendesk.com/hc/en-us/articles/201802086-Human-Resources-User-Guide
https://rfmsinc.zendesk.com/hc/en-us/articles/201892066-Provider-Rate-Matrix-User-Guide
https://rfmsinc.zendesk.com/hc/en-us/articles/201638996-Certified-Payroll


Worker Designations & Pay Types 

Accounting > File > Human Resources > File > Worker Information 

General Information Tab – houses basic personal information  

Check Boxes: 

Active – Indicates the worker is currently active and will show up in the Prepare Pay Processing 

Provider – Check this box for all workers who will provide services that will be posted as a cost against 

jobs in Providers Module of Order Entry.  This box must also be checked for this worker to be available 

for jobs to be scheduled in Schedule Pro.  This also activates the Pay status and Do not Accrue boxes in 

the bottom right.   

Scheduler – allows this worker to be available in Schedule Pro to Schedule Jobs, if Provider is also 

checked the worker will be available to be scheduled for jobs.  

Post Provider through HR – allows the worker’s provider earnings to post from Order Entry 

automatically, making the process more efficient.   

Union, Cleaning & Apprentice - are for reference and print on reports.  

 

    
 

  

Pay Types: 

Designates whether the worker is W2 or 1099.  Choices for W2 worker include Hourly, Salary & Salary 

plus Commission.  The pay type is locked to W2 or 1099 as soon as you save the record and cannot be 

changed.  W2 workers type can be edited between hourly, salary & salary plus commission.   

   

 

 

Comp. Code: 

Accounting > File > Human Resources > File > Compensation Codes 

The Workman’s Compensation Code is assigned to W2 employees by the insurance company.  When 

added to the worker file, a report can be generated for a specific period to reflect the totals of each 

category.  These reports are invaluable for your yearly Workman’s Compensation audit.   

 

 

 

 



Departments:  

This feature is used to departmentalize payroll and has two main purposes: 

1. Multiple users may now be preparing payroll at the same time 

2. Employees may be separated into departments in order to password protect different levels of 

payroll information 

 

 

 
It can also be used to separate employees who participate in direct deposit from those that don’t to make 
processing more efficient.   
https://rfmsinc.zendesk.com/hc/en-us/articles/115012915088-Departments-Set-Up-Unlock-System-Option  
 

 Pay Status:  

When a worker is checked as a Provider, choose from this field whether or not their provider records entered in 

Order Entry will post to HR from Providers pay.  One reason to make a provider do not pay in this location would 

be they are a salaried employee, but provider records will be entered on orders to affect job costing.  

 

  

You can also set up other reasons for this option and the feature can also be utilized on the individual Providers 
Earning record in Order Entry.  To learn more about how to set up additional reasons, click this link:  
https://rfmsinc.zendesk.com/hc/en-us/articles/201546347-How-to-Set-up-Pay-Status-in-Order-Entry  
 
Do Not Accrue: 
This is an ERRM function that should be checked to not post providers earnings for this provider to Accrued 
Labor.   If checked here in the worker record, it will be inherited on the individual provider records as well.   
https://rfmsinc.zendesk.com/hc/en-us/articles/204844897-ERRM-Postings-Chart-Regular-Billing 

Email Stub: 

If utilizing Direct Deposit within RFMS, you may elect to email payroll stubs by entering email and checking box. 

https://rfmsinc.zendesk.com/hc/en-us/articles/201638686-Direct-Deposit-User-Guide  
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Leave Accrual System Option 

Any Module > Utilities > System Options > System Wide > Accounting – under Configuration Category named Set 

Leave Specifications (Sick, Vacation, Holiday, Other) 

This feature allows the accrual of sick & other leave time to be set up. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For additional information on setting up Leave Time Accruals see these Zendesk articles: 
https://rfmsinc.zendesk.com/hc/en-us/articles/115004020148 

https://rfmsinc.zendesk.com/hc/en-us/articles/216185087-Set-Up-Leave-Specifications-Sick-Vacation-Holiday-Other-

System-Option 
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Personal Deductions 
This screen allows entering deductions that will be withheld from the employee or subcontractor paycheck.  

The percentage rate or an amount, limit and cycle can be entered to have the system keep up with specific 

deductions.  Examples include 401K, Health Insurance, Garnishments, and Installer Retainage for 1099 

workers. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

*Be sure to check the Perpetual box when entering Installer Retainage so they are not cleared at year end. 

 

 

 

 

 

 

 

 

 

 

 

https://rfmsinc.zendesk.com/hc/en-us/articles/115015409088-Personal-Deductions  

https://rfmsinc.zendesk.com/hc/en-us/articles/115015409088-Personal-Deductions


Provider Matrix & Certified Payroll Set Up 

 

Certified Payroll 
This program allows you to classify your workers Skill Levels, set up Prevailing Wages using Provider Matrix, 

and print the required Certified Payroll Report.   

 

Provider Matrix 
This program allows you to apply & keep track of multiple rates based on many different criteria.  It can be set 

up as simple or complex as needed for your individual business.  The Provider Rate Matrix can be used when 

creating records from Order Entry, Schedule Pro or both. 

 

These features are provided at no charge; however, training must be arranged to ensure successful execution 

of the set up.  The system will be activated by your trainer.  Please contact your RSA for details.   

Any Module > Utilities > System Options > System Wide > Creating & Balancing Provider Records, Provider Rates 

Matrix, Certified Payroll & Union Payroll – under Configuration Category 

 

 

 



 

Set Up Provider Rates Matrix & Certified Payroll Records 

Accounting > File > Human Resources > Utilities > Provider Rates Matrix 

The top section of the screen is used to search for rates from the browse list using many different filters once 

they have been created.   

 

 
 
Click the Insert icon or insert key to create a new rate record.   
Click the Copy icon to copy the highlighted rate record as the basis for creating a new rate record.   
Click the Edit icon to change the highlighted rate record. 
 



Post Providers Earnings 
There are 3 ways to post providers earnings to a job.  The first two are in Order Entry and the third is only 
available with Schedule Pro. 
https://rfmsinc.zendesk.com/hc/en-us/articles/205660607-Adding-Provider-Records  

Method One 

Order Entry > File > Providers 

This allows you to enter a batch of charges when you don’t need to see the labor budget of the individual 

orders. 

Method Two 

Order Entry > Customer Orders – search specific order click on Post Provider Information Icon  

This allows you to post charges to a particular order without opening the order but allows you to view the 
budgeted labor amount per Product Code.  You may also elect to open the order to view the labor line details 
and the Post Provider Icon is also available from within the order.   
 
Both methods above use the same Adding a Provider Record screen as shown below.  Another difference in 
using Method One is that you will need to enter the Invoice Number in Order Details where using Method Two 
that information pulls from the order. 

https://rfmsinc.zendesk.com/hc/en-us/articles/205660607-Adding-Provider-Records


Method Three 

Schedule Pro > File > Create Provider Records 

This allows you to automate the process entirely by tagging the records that are being billed and clicking 
Create Provider Records for Tagged Lines.   
 
 
 
 
 
 
 
 
 
 
 

Provider Matrix in Order Entry 
Using Method One or Two, once you have filled in the fields for Provider & Service, you will note in the center 

of the record it says Matrix Rate Information Not Applied.  You will then click on Auto Match from Matrix and 

if there is a corresponding record that matches, the rate from the Matrix will replace the existing rate and a 

green check mark will replace the red words Not Applied.  You also have the option to click on Select from 

Matrix to choose from the list.  If more than one matrix record matches your Provider Record, this same 

screen will open and allow you select.  You may also click on the Magnifying Glass icon  to view the 

matrix record details.  

    

 

 

 

Provider Matrix in Schedule Pro 
Using Method Three, first check the Use Override Rate to Create Provider Records box.  The next box is 

optional and is designed to ignore sending over any records where the override rate is 0.  Your options are to 

highlight one record and click Select Override Rate from Provider Rate Matrix for Highlighted Record or tag all 

the records you are paying and click Set Override Rate Using Auto Match from Provider Rate Matrix for all 

Tagged Records.  Any records automatically matched will remain tagged and those not matched will lose their 

tag.  The override rate from the Matrix will appear in green. 



Certified Payroll  
Once the Provider Record is created, check the box to Use Certified Payroll and then click the Matrix button to 

pull in the Prevailing Wage record.  The Required Earnings info will appear Green if the Requirements were 

met and red if they were not.   

 

You can also see this distinction on the Browse Provider Records screen as shown below. 

 

 

   

 

 

 

 



Providers Earnings Reports – Preliminary, Print & Post and History Reports 

Order Entry > Reports > Providers Earnings Report 

After all the earnings have been entered into the Provider file, it is necessary to run the Provider Earnings 

Reports to complete the processing of Installer Payroll.   

 

Note, we have changed the format for these reports from a drop down to 

individual buttons, which allows them to be password protected.   

 

 

First, select Preliminary Print.  Only records that are unpaid will show up on 

this report.  You should run this report to review the postings for errors and 

omissions and reconcile against your work order invoices.   

 

Select a combination of the available fields 

to specify a variety of framing parameters.  

For example, you may process payroll for a 

single provider and/or specify date ranges 

that correspond to the payment cycles.   

 

The next step is where you mark the 

records appearing on the Preliminary 

Report as Paid.  This is referred to as the 

Final Print & Post routine.   

 

This will produce a report that contains the 

same information as the Preliminary Print, 

with any corrections of course.  These 

records are now posted and waiting to be 

paid over in HR.   

 

 

There is also an option to Unpost if mistakes were made that were not caught prior to posting.  This option 

requires an Access Code - https://rfmsinc.zendesk.com/hc/en-us/articles/202516423-How-to-Obtain-Online-

Access-Codes  

 

 

https://rfmsinc.zendesk.com/hc/en-us/articles/202516423-How-to-Obtain-Online-Access-Codes
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Preparing Payroll 
Accounting > File > Human Resources > File > Prepare Pay – select options All Workers, Employees Only or 

Subcontractors Only 

Our Human Resources module is designed to make your payroll and subcontractor processing quick, easy and 

accurate.  Regular employees, commissioned earners and subcontractors may be processed through a variety 

of pay schedules.  Includes complete tax reporting as well as: 

• Manages all types of employees and pay schedules. (Hourly, Salaried, Contracted employees; Weekly, 
Bi-Weekly, Semi-monthly, Monthly pay periods, etc.). 

• Maintains complete payroll history. 
• Prints year-end W2, 1099 & 1095-C forms. 
• Automatically integrates to General Ledger. 
• Handles all payroll deductions including deductions applied to purchases from the company. 
• Tracks earnings for each Workman's Compensation type. 
• Tracks remaining vacation, sick, holiday and other types of leave available. 
• Handles Pre-Tax deductions (401k, cafeteria, etc). 
• Calculates salesman's commission based on job as a whole or line by line. 
• Wide variety of commission scales available. 
• Annual updates from RFMS are available and update the withholding tax tables for all 50 states and 

Canada. 
 

Select the appropriate Pay Cycle(s) & Department(s) to process.  If you are running installer payroll, you will 

also want to check the box Post HR from Paid Providers.  Enter the date from the Providers Final Print & Post 

report and this pulls those provider records into the prepare pay screen to process.  You may wish to select 

Top Slots from the options below so that your current payroll is always in the first slot and overwrites the 

previous information. 



Preparing Payroll Screen 
This screen is where the information necessary to produce a paycheck is entered.   

The top section is for Earnings and there are 10 fields available to select from Earnings Type by clicking F8 or 

enter your own description. 

 

 

In the middle section, you can record the amount of sick, 

vacation, holiday or other leave taken on this pay period while 

seeing how much time is available. 

 



The Bottom section is for Deductions with 10 fields available, you may select from the F8 list or specify your 

own description.  This is where you will pull any Personal Deductions entered on the Worker file into payroll.  

Once selected, this information will remain until you remove it.   

 

When all Earnings, Leave & Deductions are entered, click the Pay button, this will provide a Pay 

Information Screen to review the postings and ensure accurate processing.   

 

 

 



 

You may wish to run a Preliminary Report to also verify 

and confirm the accuracy of the payroll 

prior to printing the checks.  Click the Preliminary button 

to produce the payroll reports for review.   

 

You can select which report(s) you would like to preview, 

I find the Detail Report is sufficient for this step, but you 

may wish to view the paystubs and GL Distribution report 

as well.  These reports can be previewed on screen to 

save time and paper.   

 

 

 

 

 

The last step is to Print the checks and final reports by 

clicking the Print button.   

 

Here you will select the Checking Account to use, the 

date for the check, as well as some other options that 

effect how the information is displayed on the check.  

These check box options are sticky and will remain as 

selected until changed.   

 

 

 

 

 

 

 

 

 



Human Resources Reports 
Accounting > File > Human Resources > Reports  

 

 

 

 

 

 

 

 

Pay History Report 
This selection allows you to print pay history reports using the following parameters: 
https://rfmsinc.zendesk.com/hc/en-us/articles/201556927-How-to-Run-Pay-History-Reports 
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Tax Responsibility Report 
This selection prints the pay history reports for the dates chosen: 
https://rfmsinc.zendesk.com/hc/en-us/articles/201556677-Tax-responsibilty-reporting-Medicare-Tax-
when-total-included-in-FICA 
 

 

 

 

 

 

 

 

 

 

 

 

Worker’s Compensation Report 

This selection prints the worker’s compensation report providing you have set up the Compensation codes 

and assigned to each worker.  You will be asked to enter you Experience Modifier, this figure is determined by 

the state based on your previous record and number of insurance claims submitted and may or may not be 

applicable in your situation.   
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Quarterly Report 

This selection prints an earnings report that is suitable for assisting you calculate your quarterly payroll tax 

liability.   

https://rfmsinc.zendesk.com/hc/en-us/articles/215554218-Completing-the-941-for-the-last-quarter-of-the-

year 
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Worker Information Report 

This selection allows you to print a personalized worker information report using multiple parameters. 

 

 

 

 

 

 

 

 

 

 

 

 

 

End of Year Reports 

This selection allows printing of all reports needed to close out your year.  We normally have a few webinars 

at the beginning of the year covering this topic in more detail.  You may view this year’s webinar by clicking 

the link below. 

https://rfmsinc.zendesk.com/hc/en-us/articles/360000370748-Month-End-Year-End-Close-Webinar 

https://rfmsinc.zendesk.com/hc/en-us/articles/201559467-End-of-Year-FAQ 
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Certified Payroll Report 
Order Entry > Reports > Certified Payroll 

This selection prints a listing of certified payroll for a specified period.  The system will default to the last 

payroll paid date. 

 https://rfmsinc.zendesk.com/hc/en-us/articles/115012965028-Certified-Payroll-Report  
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