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Getting Started 

Installing Schedule Pro  
The executable for this program will be included with the RFMS program, licensing the software 
will be necessary.  

Starting Schedule Pro 
There are 3 ways to open Schedule Pro. 

1. After installing, a Schedule Pro shortcut will be placed on the desktop.  Click the icon to 
open the program.  (TIP: a shortcut can be created on the server and moved to the 
desktop of other workstations on the network as needed.) 

2. Schedule Pro can be opened from the RFMS Navigator. 
3. The program may also be run from the Windows Start Bar and by clicking on 

Start>Programs>RFMS for Windows>SchedulePro 
 

Setting up Schedule Pro 
 

Before scheduling jobs can begin, some system configuration is necessary.  Most of this will be 
covered in the Schedule Pro training session, included with the purchase of Schedule Pro. The 
system Setup areas for Schedule Pro are shown below.   
 
This checklist can be used during the setup process.  Click on the item for details.  

o Order Entry Configuration  
o Set Up 

o Job Types  
The Job Types entry is the most important part of the setup process.  It is the key to 
how capacity tracking of crew and depots function and how installers are separated 
based on the different materials they install.  
o Installation Depots 
An installation depot is a group of installers, it is not necessary to have more than 
one depot.  
o Crews 
A “crew” in schedule pro can be an installer or it can be a record for an installation 
subcontractor who has several people working for them but gets scheduled as a 
single unit.  
o Job Time Slots  
o Skill Levels  
o Job Status  
o Tracking Tables  
o Stores 

o System options  
o Passwords 
 

Schedule Pro Buttons in RFMS: 

 
This icon indicates that the line item or job has already been scheduled.  It might be seen in an 
Order Entry browse or when choosing a job in Schedule Pro. 

Alert Indicators 

https://rfmsinc.zendesk.com/hc/en-us/articles/201631636-Passwords
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These are optionally shown based on the setting in Utilities>System Options>Order 
Entry>Alerts>Display Schedule Pro Alerts on Order Entry Browse 

  
This icon will appear in the Order Entry browse and it indicates that there is an outstanding 
Order Entry Alert for this job.  This indicates that the order has been changed since the job was 
scheduled and the scheduled job HAS NOT been changed to reflect the order changes. 

  
This icon will appear in the Order Entry browse and it indicates that there is a To Be Scheduled 
alert outstanding for this order. 

  
If a job is scheduled for more than one day, a BLUE Plus sign is displayed next to the Start 
Date in many of the Schedule Pro screens. 

 
Scheduling/Editing Jobs  
Scheduling or editing jobs in schedule pro can be done from various areas of Schedule Pro and 
Customer Orders.  Click the marked section to see details on each area.  
 

1. Customer Order or Claim >Schedule Pro Button  or  
a. Opens Schedule New Jobs 
b. Create an alert for a job to be scheduled 

2. Scheduled Jobs  Insert button opens Schedule New Jobs 
3. Schedule New Jobs  
4. Quick Schedule  
5. Quick Edit  
6. Weekly Grid Insert button opens Schedule New Jobs 
7. Daily Grid Insert button opens Schedule New Jobs 
8. Order Entry Alerts  
9. Orders Ready to Schedule –Add to Schedule Button opens schedule new jobs screen 

with the job information 

Schedule Pro Main Menu 

 
 
The first time entering the Schedule Pro system a decision of the default screen to open will be 
made.  Select the screen most often used.  
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To change this later, go to Utilities>System Options>Schedule Pro>General>Screen to Display 
on Start Up 
 

 Regardless of the choice here, if the option is set to open schedule pro for the selected 
order, pressing the schedule pro button on the orders browse will open the schedule new job 
screen. 
 
 Multiple Screens can be opened at the same time.  This new design should allow a job to be 
scheduled from Order Entry even if Schedule Pro is already open.  It should just open another 
instance of the Schedule New Jobs screen. To see all screens open at the moment, go to 
Window and a listing will be shown.  The screen currently being viewed will have a check mark 
beside it.  
 

 

File Menu  
Options for Scheduling new jobs and working with already scheduled jobs are located under this 
menu. See below for details on each of these options.  

 
Figure: Schedule Pro File Menu 
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Edit for Job Screens 
The edit menu options vary depending on the screen open at the time.  

Reports 
Schedule Pro Reports have their own menu.  

Click to see report details. 

Utilities  

 

System Options and set up are located under the utilities menu. A maintenance menu is also 
under the utilities.  The calculator and calendar found in other RFMS modules are included in 
Schedule Pro.  

Window 
The bottom part of the screen lists all windows open in the current module. The one currently 
being viewed is checked.  To view a different window, click it with the mouse.  

Help  
Schedule Pro has a web based help file.  

Navigator 
Every RFMS for Windows module has a Navigator that serves as a "Main Menu".  The main 
RFMS Navigator allows the user to access different modules within RFMS.  After selecting one 
of the options, the main screen for that module will appear.  

Mail  
Allows access to the internal RFMS mail system 
 

Utilities 
Schedule Pro>Utilities 

System Options 
>Utilities>System Options>Schedule Pro 
 
Assigned and User options are user specific.  These settings are stored in the database. These 
options relate to a Windows User login, regardless of the specific computer or workstation.  
 
Version 12.0 conversion notes: Some order entry settings were included as view only in 
Schedule Pro. Since all options can be viewed from any modules, these are no longer 
associated with schedule pro.  
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Example:  

 

Capacity Settings 
Schedule Pro>Utilities>System Options>Schedule Pro>Capacity Settings or 
X>Utilities>System Options>Schedule Pro>Capacity Settings 

Type- Must be Global   

The options for viewing and calculating capacities for the entire installation depot are set with 
these options. The capacities for each crew will be set in the crew set up.  Capacities are the 
totals of materials or jobs which can be completed in a day. 
 

 
Figure: Capacity Settings 

 

Calculate Installation Depot Maximum Capacity Based on: 

Automatically Calculated from Crew Capacities (Recommended Setting)  
This choice sets Schedule Pro to add capacities for the depot(s) and, thus, for the company, 
based on the daily capacities for each Crew and the days of the week they work by default.  
This is recommended because it changes dynamically over time as crews are hired and leave.  
It also eliminates the need for manual entry of crew capacities.  See Installation Depots. For an 
explanation on these calculations, click here.  

Manually Entered Depot Capacities 
If this option is chosen, the installation depot capacity grid (Schedule Pro>Utilities>Set 
Up>Installation Depots) becomes editable.  The number of feet, yards, etc. of each job type that 
can be installed in a day in that depot can be manually entered.  If this method is chosen, the 
totals should be evaluated every few months as capacities change. If this setting is changed 
after jobs have been scheduled, those existing jobs will be set to deduct 1 crew for each job 
scheduled. See Installation Depots. 
 

The Installation Depot Capacities Based On setting can be switched back and 
forth, but any manually entered capacities (option 2) would have to be re-entered each time the 
setting is changed. 



 

Version 19.0  8 
 

 

Adjust Installation Depot Capacity Levels-Day 
Each day of the week, 100% of crew capacities can be shown as available on the Schedule 
New Jobs calendar, or the days of the week can be adjusted individually.  By default, manually 
entered depot capacity will show for each day of the week, or crew capacities will be added up 
for depot totals based on their daily quantity limit and the days of the week that they work.   
 
For example, if  Schedule Pro is calculating capacities, and capacities are displayed by crew, for 
10 carpet providers, each of whom can install 100 SY per day, and half of them work Saturday, 
at 100%, the Schedule New Jobs calendar will show 10 Crews on Thursday, 10 Crews on 
Friday, and 5 Crews on Saturday.  If it is known that some providers will no-show on Friday, it 
can be adjusted down to 75% so that it will show 10 Crews on Thursday, 7.5 Crews on Friday, 
and 5 Crews on Saturday.   
This can be used to set all days down to 95% to give a cushion against overbooking.  This may 
be adjusted over time as Schedule Pro becomes more familiar.  

If all crews are set to have Sunday off, these don’t need to be adjusted down at all, 
as there will be no depot capacity on Sunday.  
 
After adjusting these settings, go to Schedule Pro>Utilities>Maintenance>Reset Depot & Crew 
Capacities. 
 
 

Maximum Jobs per Day per Crew 
This is applies to all crews, regardless of capacity or of what has been entered in their individual 
crew record.  This corresponds with the Warning Message called "Exceed Maximum Days per 
Crew."   It works very simply:  if "3" is entered in this field, it will trigger the warning any time a 
crew is scheduled for the fourth job for that day.   
 

Use Linear Meters:  
Select this option to use Linear Meters in calculations.  
 

View Installation Depot Capacities By: 
This first section pertains to the Schedule New Jobs screen, particularly the calendar on that 
screen that shows how much capacity is left available for each job type (i.e. Carpet or Vinyl) for 
each day in the next four or five weeks.   
 
The program calculates available capacity by subtracting the amount already scheduled for that 
day from the footage or yardage, or subtracting a crew based on the average number or feet or 
yards a crew of that job type can install.  The default must be set one way for the whole 
company. 

Number of Crews Available  
Choosing this option displays the capacity left available for scheduling in "Crews."  If the 
average yardage for a carpet crew in the system setup is 125 SY, it will subtract 1 Crew for 
each 125 SY, regardless of how many crews are assigned to the job.  It will subtract .8 crews for 
100 SY in this example, and so on.   



 

Version 19.0  9 
 

Quantity Available 
This option displays the number of feet, yards, hours, or "each" available in that job type for a 
certain day.  This is a good choice if the capacities of each crew vary a lot, as the actual 
yardage available on a day will give more information than the number of crews.   
 

Deduct Crews from Installation Depot Capacities Based On 

This feature is only available if the "View Installation Depot Capacities by" 
switch is set to "Number of Crews Available": 

Automatically Calculate based on Line Quantities (Recommended Setting) 
This choice sets the Schedule Pro to deduct capacities from a provider’s day and from depot 
capacities for that day based on the line quantities (those that are checked to be deduct 
capacity lines – See Job Types and Schedule New Jobs.)  This is recommended because it 
allows taking advantage of the dynamic features of Schedule Pro that reduce capacities based 
on various different job types and unit of measure for a single job if it is set that way.  Also, it 
allows taking advantage of warnings that are built in to prevent overbooking a person or a 
depot.  Most users are scheduling using this setting. 

Manually Enter Number of Crews to Deduct  
If this option is chosen, a box appears when scheduling or editing job, in which the number of 

crews to deduct for a job for a certain day can be entered.   
 
In this box, the number of days times the number of crews can be added when a job is 
scheduled, and it will reduce the capacities of the crews chosen and the depot accordingly.  It 
bypasses the usual deduct capacity methods used in Schedule Pro and puts the direct control 
of the days in the hands of the scheduler, but it also bypasses some of the safeguards against 
over-scheduling.   
 
 

General 
X>Utilities>System Options>Schedule Pro>General Category Authorization 

Authorization 

 

Type- Can be Global, Assigned or User 

Display System Setting Restrict Message as a Warning Message 
This functions as a "Manager override" for any Schedule Warnings that are set to the "Restrict" 
setting.  For example, if a System Settings Warning is set to restrict, then a normal user tries to 
perform the action, they will get the following message, and will not be allowed to add the job to 
the schedule: 
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In the same scenario, a user with this box checked would only get a warning message, allowing 
the user to add the job at his or her discretion. 
 

 
 

Open Schedule Pro in Read Only 
To set up a certain workstation or user for Read Only access to Schedule Pro, click the button 
labeled "ENABLE READ ONLY SETTING" and choose "Always."  Close and reopen the 
Schedule Pro, it will now be in read only mode.  The Enable Read Only button should be 
password protected so that the Read only setting cannot be changed by anyone without the 
password. Opening Schedule Pro in Read Only Mode from Order Entry - will now open View 
Schedule Jobs and display related jobs if scheduled jobs exist. 
 
An administrator may want to be able to see both Read only and full edit modes at different 
times.  In this case, choose Select on Open, and a prompt to choose an edit mode will display 
whenever Schedule Pro is opened.  
 
Read only users have access to fewer options as illustrated in the File menu example.  

 
Figure: Read Only File Menu  

Instead of the Schedule New Jobs screen, they have a Calendar View Screen listing the 
scheduled jobs and quantities left available.  
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Figure: Read Only Calendar View 

Users viewing Schedule Pro in Read Only mode will not count against the 
Schedule Pro user count. 
 

View Edit Default Store Only  
If multiple users will be scheduling for their own Store Code and should not have access to view 
other Store Codes, this option, in tandem with the Current Store option will lock the user down 
into their Current Store Code.   
 
Before turning this feature on, be sure to have the correct “Current Store” selected in system 
options.   

Configuration 
Schedule Pro>Utilities>System Options>Schedule Pro>General Category Configuration or 
X>Utilities>System Options>Schedule Pro>General Category Configuration 
 

Type- Must be Global   

 
Quick Schedule Display Timeslot 1 & 2 
Choose from the predefined Job Time Slots– Cannot be edited manually.   
This defines the time slots which will be tallied on the Quick Schedule Screen.  

Default Filters  
X>Utilities>System Options>Schedule Pro>General 

Type- Can be Global, Assigned or User 
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Figure: Default Filters 

General Filters 

The Scheduling Grid, View Scheduled Jobs, Report Menu, and other screens have a Find 

button.   
 
The set up in this screen determine how these filters will be set when the screen is first opened. 
This is a time saving tool. The filter settings can be changed while the screens are open, but will 
revert back to the defaults the next time the screen is opened. To go back to the default settings 

while still in the screen, use the reset button.  The clear filter button   will set the find to 
include all records.  
 

 
If experiencing slowdowns in Schedule Pro, setting more filters to blank should improve system 
performance speed. 
 

User Defined 1 & 2 
Under the General Filters section, if User Defined 1 and 2 fields are not used, set this to "All."  
This will prevent filtering based on an unused field.  If User Defined 1 or 2 has been renamed to 
be able to use it to say whether a job is "Business Sector = R” or has been "Confirmed," for 
example, choose to filter on these each time a screen is opened.  If expected records are not 
found, check the filter settings. In this case, be sure to switch both to "All" in the yellow filter box 
to show jobs, regardless of the value of these switches. 
 

Date 
There are three options here: 

Specific 
This defaults to one specific date.  With this selection, when opening View Scheduled 
Jobs or the Report Menu, for example, they will automatically be filtered to the current 
date.  A different single date can then be chosen. 
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Range 
This defaults to a date range, which will initially be set for beginning with the current date 
and two weeks forward.  Again, once in the screen, the start and end dates can be 
changed to a different date range.  This is the recommended setting if speed is not a 
huge issue. (Reports will default to using range regardless of the setting here.)  

All 
This doesn’t filter based on date at all.  This will work best for opening screens quickly if 
speed is an issue.  On the View Scheduled Jobs screen, all jobs will appear in the 
browse box, but the first job for the current day will be highlighted.   

General Filter Job Status 
This field allows selection of one of the Job Statuses from the Job Status list as the default 
when using the custom filter option throughout the Schedule Pro module.  For example, select 
"In Progress" to automatically filter out jobs of any other status.   
 

Installation Depot 
This works the same way as the store code filter.  If scheduling for one depot, to see that depot 
only, select it here.  To view the whole schedule, select all. 

Job Time Slot 
This pulls from the Job Time Slots list, and allows filtering by only one job time slot as a default.  
The recommended setting for this filter is to leave it blank.  

Job Type 
This will automatically apply a filter based on one of the Job Types set up for Schedule Pro.  If 
Carpet Jobs are the only ones scheduled, for example, apply this filter to automatically filter 
down to just carpet jobs whenever a screen to view jobs or run reports in Schedule Pro is 
opened.   
 
For a repair job, for example, that has no lines in product codes that are associated with the 
Carpet Job Type; it will be filtered out using the Job Type filter.  A job must have at least one 
line with the Job Type selected to appear once this filter is applied.  

 

The next two options select the default filter for the Select Order to Schedule 
Screen 
Clicking the F8 button on the Schedule New Jobs screen to pull up an RFMS Order, gives 
options for the filtering that display.   

 
 

Select Order Screen Default Order Type 

Type- Can be Global, Assigned or User 
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The selection made here will set the default order type shown. Selecting a different option will 
temporarily display a different list of orders.  

All 
This doesn’t filter based on whether the RFMS Order is an original order, a claim, or a 
job costed order.  This is the speediest way to pull up the list of jobs. 

Current Original 
This filters out all Job Costed orders and all Claims.  If scheduling for Job Costed orders 
is not allowed this makes the most concise list.  However, this option may cause a delay 
on some workstations. 

Current Claims   
This will pull up open orders from the RFMS claims module only, and would only be a 
good filter for someone who is scheduling service and/or claims only. 

 

Select Order Screen Default Tab 

Type- Can be Global, Assigned or User 

Once a list of the RFMS Orders from Order Entry is displayed, there are various tabs with 
different sorts and search options that help locate the correct job to schedule.  Choose which 
one comes up by default in this list, for example, choose to sort by Estimated Delivery Date.  
 

Sort By  
This sets up a sort for any reports printed (with a few exceptions, like Crew Names & Contacts, 
that have their own sort hardcoded).  Options include: Order Number, Customer, Crew, Ship to 
Name, Stop, or “Job Number”, which is a user defined field in RFMS, and may be called “Side 
mark,” “Job / Lot,” “Add’l Info” or something else.  
 

 

Store 
This field allows selection of “Current Store" or "All Stores" as the default when using the 
custom filter option throughout the Schedule Pro module.  If a user always schedules for Store 
Code "1" in Phoenix and should not see any of the jobs scheduled for Store Code "2" in Tucson, 
for example, filter to Current Store, and they will always see Store Code "1" jobs as long as the 
last job they were working with was a Store Code "1."  If a user schedules all jobs regardless of 
Store Codes, leave this set to All Stores. 

Default Values 
Schedule Pro>Utilities>System Options>Schedule Pro>General>Default Values or 
X>Utilities>System Options>Schedule Pro>General>Default Values 

Type- Can be Global, Assigned or User 
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Default User 
This will save time in data entry, as a name must be entered each time a job is added or edited 
in Schedule Pro. First click "Edit User Name".  Select a user.   For a person to be included in the 
pick list, they must be checked as a Scheduler in RFMS Human Resources. 

Schedule Pro Default Store 
This displays the store code setting that is current in Schedule Pro.  If default filters are set to a 
certain store code, the Current Store can be changed here.  It can also be changed at various 
places throughout the program that have this icon: 

Display 
>Utilities>System Options>Schedule Pro>General>Display 

Type- Can be Global, Assigned or User 

 

Display Availability on Schedule New Jobs Calendar 
This will turn off the color coded "Crews" or "Quantities" that display whether the crews in the 
depot is already booked or fully booked for the day in question.  This option has will make the 
Schedule New Jobs screen open and run faster. 
 

Limit Quick Edit Screen to 1 Store or 1 Depot at a Time 
The Quick Edit screen allows filtering to a batch of jobs based on Date Ranges, Store Codes, 
Depots, Job Types, and other criteria and then tagging and editing those batches of jobs.  The 
Primary Crew, Job Status and other information can be changed.  If a user is scheduling for one 
Store Code or one Depot, to avoid the risk of editing the jobs for other Store Codes or Depots 
that might be kept separate at the company, check this box.  This will require a Store Code or 
Depot selection before allowing any batch edits.  For one Store Code, leave this box unchecked 
to avoid having to make unnecessary selections on the Quick Edit screen. 
 

 
• Before turning this feature on be sure to have the correct current store selected.  Both 

the Edit View Current Store Only and the Edit Current Store buttons will need to be 
password protected. 

 

• The 4 update and delete alert buttons in the Alerts screen will affect all jobs, not just 
those that are for the current store, even with this setting in place.  Password protect 
these buttons as needed. 

 

Display Crew Availability Dots on Select Crew Screen and Grids 
Setting this to yes will turn on the color coded dots that display whether the crew is already 
booked or fully booked for the day in question. A black dot will still be displayed for days crews 
are off or unavailable.  This option has been added for those users who are looking for an 
increase in speed. 
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Display Material Status Delta on Grids 
Setting this option to yes will display the material status indicators on the detailed grid. This 
refers to: material status triangle color coded icons.   

Interface 
>Utilities>System Options>Schedule Pro>General>Interface 

 

Enable Drag and Drop 
To Enable Drag and Drop on the Scheduling Grid for this user, click "Edit Drag and Drop" and 
check the box. 

Job Scheduled Screen from Order Entry 
A simple version of the Schedule New Jobs Screen is now available.  The selection of which to 
use is made here.  
 

The Simple Job Schedule Screen  

 
 

Screen to Display on Start Up 
Choose the screen to automatically open without having to go to the file menu first when 
opening Schedule Pro.  

Prompts 
>Utilities>System Options>Schedule Pro>General>Prompts 
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Figure: Prompts 

 

Type- Must be Global   

 

Tracking Table 1 and 2 Description 
These can be up to 30 Characters.  Tracking Table 1 and 2 allow tracking and reporting on 
scheduling activity.  This tracking or categorizing of scheduled jobs is user definable.  The data 
entry in this field is names that category.   
 
The options for these tables will be added later in the set up process.  

 

To assign tracking to a scheduled installation, click the F8 button for the tracking 
field that is located in the lower right hand portion of the Schedule New Jobs screen.  See 
Scheduling Jobs. 

Reporting 
>Utilities>System Options>Schedule Pro>General>Reporting 

 
Figure: Reporting 

Company Name for Reporting 

Type- Must be Global    

This can be up to 50 Characters.  When Schedule Pro is licensed, the company name will be 
filled in from the RFMS Company Information file.  This field prints on the footer of all reports.  
The Company Name CAN be edited so that it differs from that of "regular" RFMS on Screens 
and Reports. 
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Default Path for CSV Reports:   
Each user can set the location for any reports they “print” to a file, rather than to paper.   

Warning Message  
>Utilities>System Options>Schedule Pro>General>Warning Messages 

Warning When Changing Stores 
If a user schedules orders related to various RFMS store codes, but they are not separated by 
store code for scheduling purposes, turn this checkbox off so the system will allow switching 
between store codes without generating a warning. 
 
For different store codes for different locations, with some users only scheduling for one of 
those store codes, this warning will be sure they know if they accidentally pull a job from Order 
Entry that is in a different store code: 

Order Entry  
>Utilities>System Options>Schedule Pro>Order Entry 

 

Type- Can be Global, Assigned or User 

 
 
 
 

Allow User to Edit Order Entry Notes 
Setting this option to yes will allow this user to edit the Notes attached to the RFMS Order. This 
includes the RFMS Order Internal Notes, RFMS Order Custom Notes, RFMS Work Order 
Custom Notes, RFMS Order Line Notes and RFMS Work Order Line Notes.  
 

Type-Must be Global  

Allow Job Costed Orders to be Scheduled (Yes / No Option)   
Most companies set this to NO.  The one reason to have this switch set to Yes is the ability to 
pull over an Order Header to schedule a non-warranty or non-paid repair that is not being 
entered in Order Entry.   
 

Automatically Set Order Line Status  

No 
 Does not change the line status 
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Cut 
The line status will automatically be changed to cut when the provider record is created 
by checking this box.  

Delivered 
The line status will automatically be changed to delivered when the provider record is 
created by checking this box.  
 

Automatically Tag Order Lines when Scheduling New Jobs 
This setting refers to the way an order first pulls in the Schedule Pro in the Schedule New Jobs 
screen.   

No Lines  
If multiple “trades” are entered on an order, this would be the best choice.  This pulls the 
lines over untagged, and the person doing the scheduling can tag the lines they’d like to 
schedule.   

All Lines  
If the orders are generally entered separately for Carpet, Vinyl, Hardwood, and so on, 
this is the best choice.  When an order is pulled into Schedule Pro, all the lines are 
already tagged.  
 
This example is a group of lines in the Schedule New Jobs screen that were pulled in 
with “All Lines” selected.  They are all tagged, even though there is a ceramic line that 
will probably be scheduled separately from the carpet. 
 

 
 

Deduct Capacity Lines Only  
This setting is for those who don’t want to put all the lines from an order onto their 
schedule.  They are scheduling based on “Deduct Capacity” lines only, which can be 
either primary service lines or primary material lines, depending on how Job Types are 
set.  This, too, is a better choice if the various flooring types are entered on separate 
orders rather than many types on one order. 

Base Schedule Pro Install Date on the Order Header Estimated Delivery 
Date 
This option allows “Estimated Delivery Date” to be a kind of default or “suggested date” when 
scheduling an order that has an Estimated Delivery Date already in the Order Header.  A 
different date can still be chosen for installation.   
 

Update the Order Line Estimated Delivery Date 
This option determines whether the scheduled date of the individual order lines updates the Est. 
Del Date on the line in Order Entry.  This won't apply to orders scheduled before Schedule Pro 



 

Version 19.0  20 
 

was licensed, but will apply to new or edited jobs.  Keep in mind the appropriate status boxes 
must be checked. 

No- This will not update line dates. 

Yes-Update Line Dates for lines with the Statuses Below - (Order Entry Job Line 
Statuses are listed)  

Recommendation:  If update Line Dates is chosen, it makes sense to update for all statuses to 
be consistent. 

Update the Order Header Estimated Delivery Date 

This determines whether the Estimated Delivery Date in the Order Header gets updated based on 
Schedule Pro dates.   
 

No Schedule Pro will not update the Order Header Estimated Delivery Date. 

Keep in mind that if Schedule Pro is updating line dates in the setting 
above, the Order Entry “Auto Post Estimated Delivery Date” system option may update 
the header date based on these line dates anyway.  See Order Entry Configuration in 
the RFMS User Guide to read further. If both of these date integration switches in 
Schedule Pro are turned on, it is best to set Auto Post Est Del Date in System Options to 
No. 

Yes- Use Order Entry Lines Only  
This updates the Order Header Estimated Delivery Date based on Order Lines that are 
scheduled.  With this setting, the header date will always show the NEXT thing 
happening on that order.  For example, if hardwood is scheduled on 6/15 and carpet on 
6/20, on 6/10, the header date will display the 15th, and on the 16th, the header date will 
roll forward to displaying the 20th, and so on.   

Yes- Use Order Entry Lines and Schedule Pro Temporary Lines 
This setting is just the same as the one above (Jobs with RFMS Order Lines Only) 
except that it also looks at the dates on “Temporary Lines” – lines that are entered in the 
Schedule Pro but do not exist in order entry – related to the order when deciding which 
date is coming up next on that order. 
 

Do not consider Order Entry Lines that are not scheduled 
Dates can be entered onto order lines by means other than scheduling. This checkbox 
helps the Order Header Estimated Delivery Date keep current even with date changes in 
Schedule Pro. It tells the system to look ONLY at lines that are on the Schedule Pro 
when determining the Header Date.  This way, even if there are a few lines for supplies 
or billing purposes in the Order that have a line date that was included when the line was 
added, the dates from these lines won’t affect the header date if the job gets moved. 
 

Overwrite Header Estimated Del Date with Blank or Past Date  
By default, if the above switch is enabled to handle the date in the Order Header, the 
program will keep the Order Header Est Del Date updated, unless a job is changed to a 
date that has passed (in the case of correcting an error on the schedule after the fact) or 
the job has been deleted from the schedule. If this box is checked, it will keep the 
Header Date updated in all cases, even a change to the past or to a blank date. 
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Providers 
>Utilities>System Options>Schedule Pro>Providers 

 
 

Populate Hours from Job into Providers Regular Time Field 

Type-Can be Global, Assigned or User 

If option is set to Yes, when creating provider records it saves the hours from the job into the 
regular time field in the provider record.   
It also follows the switch to “Use Units and Dates From” either Actual or Scheduled, and the 
switch to “Combine Split Lines and Display on Last Install Date.” 
If the hours for a job are 9 or more, an hour is removed for lunch.  For example, 8 am -5 pm=9 
hours, but 8 will be posted. 

Allow Provider Rate Override 

Type-Must be Global  

Setting this option to yes allows the rate on individual provider records to be edited before 
sending them to order entry.  

Automatically Set Product Code to 00 

Type-Must be Global  

By default, this option is set to no.  Typically, a provider record has the same Product Code as 
the line it is related to, and this allows easily seeing whether labor costs are balancing with the 
order.  If this option is set to yes, it will send the provider records with a PC of “00” so they can 
be sent to Accounts Payable if not being paid through the HR module. 

Automatically Set Rate to 0(Select One) 

Type-Must be Global  

Never (Default) 
If the provider record should use the “Cost” from the Order Line for the rate to pay the 
provider, or if providers are hourly, leave this set to “Never.”  This is the default. 

Always 
Otherwise, the provider records can set the per unit rate to “0” (to be manually filled in 
later) for all records. 
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Subcontractors Only 
For only for those installed by crews set as “Subcontractors” in the Human Resources / 
Worker Information file. 

 

Combine Split Lines & Display on Last Install Date  

Type-Must be Global  

This gives the ability to recombine the split lines back together for creating the provider records.  
The quantity for split lines that have the same:  

• Line Number 

• Crew Name 

• Job Type 

• Style  
Will be added together.  This total quantity will be used to create the provider record with an 
install date of the last day that the line was scheduled. 
 
When using this feature, the Create Provider Records browse will only show scheduled lines if 
they are on the last day that the line was scheduled and the total quantity will be displayed. 

Create Provider Records for Labor Lines with No Crew Scheduled  

Type-Must be Global  

With “create provider records with no crew scheduled” in Utilities>System Options>Schedule 
Pro>Providers>Create Provider Records for Labor Lines with No Crew Scheduled set to restrict, 
previously users were not warned that no provider record was created. Now there will be a 
message to inform the user if records were not created. 

 
 

Post Load to Provider Rate for Subcontractor’s 

Type-Must be Global  

Checking this box will allow a load in to some provider records automatically.  Load here is 
treated differently than in Order Entry so an access code is required to select this option to 
ensure that it is understood that this selection will pay (Rate + load) to non-hourly providers. 

The work order labor rate will be added in the order line load where applicable. 
 

It will cause the Load field to be used as follows when creating provider records: 
Subcontractors:     
Provider Rate = Line Rate (Cost) + Line Load 
Provider Load = 0 
              
Employees (Non Hourly):   
Provider Rate = Line Rate 
Provider Load = Line Load 
 
Employees (Hourly):   
Provider Rate = Hourly Rate  
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Provider Load = 0 

Provider Work Order Number (Select One) 

Type-Must be Global 

Empty 
This leaves the Work Order Number field empty so a provider invoice number can be 
added later if needed. 

Service Description  
This choice puts the “Service Description” of the Labor Line in the Work Order Number 
field in the Provider Record.  This description will be truncated if it is more than 10 
characters long.  It is a nice way to show what the provider is getting paid for on the 
reports. 

Order Number 
This puts the Order Number (CG number) into the Work Order Number field. 

 

Use Units and Dates From 

Type-Must be Global   

Scheduled Fields (Recommended Setting) 
This pulls the Install Date in the Provider Record from the date that the job was 
scheduled.  If this setting is chosen, it means that the Scheduled Dates will also be used 
as the Install Date.  After the jobs have been installed, the Scheduled Dates can be 
edited to reflect what actually happened, and only one set of dates has to be maintained. 

Actual Fields (See Edit & Complete / Actual Fields)  
This pulls the Install Date in the Provider Records from the date fields labeled “Actual 
Fields” in Schedule Pro, which are only used by a few users.  When choosing use these, 
a second set of dates must be filled in after the job has been completed to note what the 
Actual Install Date was, regardless of the Scheduled Date. 
 

Providers- Category Default Filters 
>Utilities>System Options>Schedule Pro>Providers 

These three options set up the default filters for the screen in Schedule Pro that allows creating 
Provider Records.  This screen also defaults to showing today as the install date. Changes can 
be made to include other records once on the screen; these settings are just the default. 
 

 
Type-Can be Users, Assigned or Global 

Default for Show Records Filter on Create Provider Records Screen 
The recommended default setting is Not Created.  This shows only labor lines that haven’t 
already been turned into provider records.  This is to prevent someone from accidentally 
sending the same record over to the Providers Module twice.  While in the Create Provider 
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Records screen, this can be changed to "Created" or "All" temporarily to see which ones have 
already been created.   

Default for Temporary Lines Filter on Create Provider Records Screen 
The recommended default setting is "No" or unchecked.  A Temporary Line is a line that is 
entered in the Schedule Pro but doesn’t exist in Order Entry.  Usually, creating a provider record 
from this type of line is NOT done.  This is because although there may be a quantity and crew 
associated, there is no cost associated with this line.   
(This does not include temporary lines on jobs without an associated customer order.) 

Default for Job Status Filter on Create Provider Records Screen 
This filter will default to the "All" status, so it will show all labor lines for jobs scheduled on the 
selected day.  Our recommended setting is to set the default to "Completed."  This forces the 
Schedule Pro user to review jobs after receiving an invoice from a provider and changing them 
to the Completed status before provider records are created.   

 

Schedule Pro 
>Utilities>System Options>Schedule Pro>Schedule Pro 

 

Type- Must be Global   

 

Crew Name Format from Worker Information File 
This sets up the default format for pulling in Crew Names from Accounting>Human 
Resources>Worker Information when initially adding crews to the Schedule Pro.  If “Worker 
Number” is not used in HR, the choice is between Last Name and First Name first.  If a “Worker 
Number” is used, it can be listed before the actual name in the Crew Name field, and, then 
followed by “Last Name, First Name” or “First Name, Last Name.” 
 

Reference Prompt 
This field is generally one that isn’t linked to anything in Order Entry and is used to enter any 
kind of invoice or work order number for jobs that are scheduled manually (that aren’t in Order 
Entry for some reason.)  To use this field for another purpose, rename it here.  Keep in mind this 
field can always be viewed with the scheduled jobs on the screen, but it does not print on many 
reports. 
 

User Defined Field 1 and 2 Prompts, Choices 1, 2, and 3 
These two fields are user definable.  These fields are Yes / No or A / B / C options.  They can 
be used for filtering jobs throughout the various viewing screens and reports.   
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Often, these are used to indicate whether a job has been confirmed or whether a job is Retail, 
Builder or Commercial.  Then the choices are defined to correspond with these prompts.  See 
the before and after examples. 
 
Before setting up user defined 1 & 2  After setting up user defined 1 & 2  

  
 
To use one or both of these fields to modify Schedule Pro jobs, set the System Options, 
Schedule New Jobs defaults to define how these will default when adding a new job, and set 
filters to show certain data based on this field when the Scheduling Grid, View Scheduled Jobs 
screen, or the Report menus are first opened. 
 
These User Defined fields can easily be used for filtering.  For example, the person who 
confirms the installations screen could be set to show only jobs that have confirmed set to "No" 
and could run through the "Don’t Knows" from time to time.  For someone who only deals with 
commercial jobs, their screens could be set to show only jobs where "Business Sector" = "C." 
 
 
 
 
 
 
 
 
 
 

Scheduling  
>Utilities>System Options>Schedule Pro >Scheduling> 

Configuration  

 
Type- Can be Global, Assigned or User 
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All Crews Tab Position 
In the Schedule New Jobs screen, there are tabs for each job type, and these tabs each display 
a calendar showing how many crews or how much quantity is available to be scheduled on each 
day.  In addition to these Job Type tabs, there is an "All Crews" tab, which shows the big picture 
view of all crews.  This order of this tab can be changed depending on the frequency used. 

Always Default to Store (Clear to Use Current Store) 
As the parenthetical suggests, for a normal user who can schedule for any store code, or in a 
case where there is one store code and the store code selection is not an issue, leave this field 
blank. 
 
To limit a user to one store code:  If a store code is selected here, the user will not be able to 
select jobs from another store code on their workstation without changing this setting.  To keep 
the user from changing their store code, password protect the F8 button and the Eraser button 
next to this field.   

Automatically Select Depot 
For a normal user using one depot, which is secondary, like a "Service" depot select one here to 
make the secondary depot for the store code the default. Typically, however, the default for the 
depot will come from the store code of the job, so the recommended setting is to leave this set 
to Primary. 

User Defined 1 & 2 (Field Defaults) 
These two fields may be called something else if they have already been defined.  They usually 
have the choices of "Yes," "No," or "DK" (don’t know.)   These choices are user defined as well. 
Regardless, each of these can be set to a default for new jobs.  For example, jobs are 
scheduled and then confirmed later; defined one user field as "Confirmed," with the default 
setting to be "No." 

Job Status Initial Value 
Most users start their jobs in the "In Progress" status.   

Job Time Slot Initial Value 
This, again, is to save time on data entry.  Select the most frequently used time slot here, and it 
will only have to be changed if another time slot is used on a job. 

Jobs Scheduled for Depot & Day – Default Tab 

  
 
In the Schedule New Jobs screen, beside the calendar that shows availability, there is a list of 
jobs scheduled for that depot and day (and job type, depending on what is selected on the 
calendar.)  This list of jobs has four tabs corresponding to four different sorts:  Primary Crew, 
Order, Customer, or Ship To Name.  This field allows the default sort to be defined.  

Jobs Scheduled – Start and End Times   
In the Schedule New Jobs screen’s list of jobs scheduled for that depot and day (see field 
above), there are fields for Start Time and End Time.  This setting determines whether those 
fields will be populated from the Start and End Time of the job’s “Time Slot” or the Start and End 
Time of the first line scheduled on the job.  In most cases, these are the same, but some users 
manually edit line times after scheduling with a generic time slot. 
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Order Type (Field Default) 
The first step in entering a job is to choose whether the order will be exported from RFMS Order 
Entry, from RFMS Claims, or entered by hand because no order exists.  To enter a job by hand, 
select "Customer" in this toggle box, then enter the job manually using temporary lines.   
 
If this option is selected, the "Customer" field becomes one of the defining pieces of information 
to locate this job.  A customer can be selected from the RFMS Customer file using the F8 
button, or just enter a Customer name in manually. This is usually set to default to "RFMS 
Original."   

Skip Saturdays, Skip Sundays. Skip Day When All Scheduled Crews Off 
These are, again, default settings, and can be changed on a job by job basis.  Most users skip 
Sundays and days when they’ve scheduled all crews off.  When a job is split over multiple days, 
these checkboxes will define which days are skipped as the quantities are distributed over 
multiple days. 

Tracking Tables 1 & 2 
These two fields may be called something else if they have been defined in set up.  Both fields 
labels and choices are user defined. To have a default value, enter it here. 

Deduct Number of Crews (Most likely grayed out) 
Most people will not see this field.  If using the method of deducting crews not based on 
capacity but based on a manually entered number, which is not recommended, enter the default 
number here.  It is usually "1." 
 
 
 
 

Warning Messages 
>Utilities>System Options>Schedule Pro >Scheduling>Warning Messages 

 

Type Must be Global 

The message notification Value allows setting the level of alert for various scenarios.  The 
restriction or warning will come up when the job is first scheduled as well as every time it is 
edited as long as the restriction applies.   
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Choose From: 

 
Restrict  

Stops the user from going forward until the appropriate action is taken. 

 
Warning 

Displays a warning and gives option to proceed (OK) or Cancel to go back and enter the 
information.   

 
No Message 

Action is completed with no message displayed. 
 
For example, to never allow any job to be scheduled without a Crew name being attached to the 
job, set that line to Restrict, and, if someone tries to add a job to the schedule without a Crew, 
they will encounter the following message and have to go back and add the Crew to the job 
before adding it.   
 

  

 

The Warning setting will show a message if the person tries to schedule without a Crew, in this 
example, but would let the scheduler override the warning and schedule the job without the 
Crew even after being warned.  The none setting ignores this particular factor altogether and 
allows the job to be scheduled with no restriction or warning.  This works well for anything that is 
often allowed so the users don’t get in the habit of ignoring the warnings. 
 

There is an exception to this, which is that there is a setting in the System Options 
screen that allows setting a manager or special user or group of users to see a “Restrict” 
message as a warning.  To use this, set the “locked down” item, such as “Crew Overbooking” to 
“Restrict” on this screen, then for  the person who can override set the Utilities>System 
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Options>Schedule Pro>General>Display System Settings Restrict Message as a Warning 
Message to yes.  (Of course, to enforce the integrity of this, password protect system options.) 
 
Most users leave these Warning Messages on “Warning” to get started.  

 

FIELDS:  Warning Choices Description 

Crew Does Not Install Job 
Type 

This warns if a crew does not install the job type they are assigned. 

Crew Does Not Work On 
Scheduled Day:   

This warns when a job is assigned to a Crew on a day he never works, 
or on a day he is scheduled to “have the day off.” 

Crew Overbooked for Day:   This warning appears when trying to assign more quantity to a crew in a 
day than they have in their Crew Capacities. 

Crew Required:   This warns when a scheduler attempts to add a job without a crew.  For 
some companies, this is how they normally schedule.  In that case, this 
can be set to “No Message.” 

Crew Time Conflict:   ALL jobs are scheduled for ALL DAY and then let the providers’ decide 
which jobs to do first, second, etc. turn this warning off by setting it to 
“None,” but otherwise, it will warn when a crew is scheduled for 
overlapping time slots in a day. 

Exceed Maximum Jobs per 
Day per Crew:   

As an example, if the Max Jobs per Day per Crew is set to “3”, this 
Restriction or Warning will come up when a scheduler attempts to 
schedule the fourth job for that day.  NOTE:  This relates back to the 
number entered in that field, not the individual Crew settings. See 
System Settings>Capacity Settings > Maximum Jobs per Day Per Crew 
System Settings.   

Installation Depot 
Overbooked for Day:   

This warning appears when trying to schedule a job that exceeds the 
depot’s capacities for that job type or types for that day. 

Jobs must be Scheduled to 
the Primary or Secondary 
Depot for the Order Store 
Code:   

If this is set to Restrict, users will not be allowed to assign a job to a 
crew from a depot that is not related to the store code of the job. If it is 
set to restrict, crews from other depots will not be available for 
scheduling.  If it is set to warning, on the Select Crew screen, they will 
have the option to check a box allowing them to see crews from “All 
Depots” regardless of which Store Code they are associated with, and a 
warning will be generated if they choose one of these crews.  Set to 
none, they can check the same box, and no warning will be generated. 

Reason for Editing Required By default, this is set to “Restrict,” which requires the user to note a 
“Reason for Edit” each time they change an existing scheduled job.  
This can be set to “Warning” or “None” instead. 

RFMS Material Order Lines 
– Check for Status Gen PO, 
On Order, or Material is not 
Available:   

This warning tells whether there are material lines that haven’t been 
ordered or received.  If jobs are not allowed to be scheduled even when 
some of the order lines are not showing as available, run a report to 
show what lines are scheduled that have a problem line status. 

This switch is applicable only if scheduling material lines vs service 
lines.  

Sales Representative 
Required:   

This warning is to make sure a Salesperson is entered in to a job.   

Scheduled Job is in the Past:   To be able to change the schedule for jobs that have already gone to 
reflect what actually happened; this warning should be turned to 
“None.”    



 

Version 19.0  30 
 

Tracking Table 1 Required Allows the user to have the ability to restrict, warn or set no message if 
a tracking table is not selected. 

Tracking Table 2 Required Allows the user to have the ability to restrict, warn or set no message if 
a tracking table is not selected. 

 
 

Scheduling Grid 
>Utilities>System Options>Schedule Pro>Scheduling Grid 

 

Primary Daily Grid Job Type  

Type- Can be Global, Assigned or User 

 
If a single job type will always be viewed on the daily grid, select that job type as the Primary 
Daily Grid Job Type. 
 
Doing so will enable a short cut button on the screen with that job type as the name. Clicking the 
button will deselect all other job types, leaving the primary job type as the only one to be 
displayed.  Use the check boxes on the grid to select and unselect job types. Use tagall to 
select all job types.  

 
Figure: Daily Grid Job Type Options 
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Deduct Capacity Lines Only 
If this checkbox is set to "Yes," only jobs with Deduct Capacity lines scheduled for a given day 
will show on the grid on that day.  So, a scheduled job that does not have a deduct capacity line, 
for example, a job that has one "Miscellaneous" line only, will not appear on the grid.  The 
recommended setting for this checkbox is to leave it unchecked. 

Scheduling Grid Job Status 
This applies a filter based on Job Status to the Scheduling Grid.  The recommended choice in 
this field is "All" so that no jobs will be hidden.  However, if a person who is just dealing with 
follow up calls, for example, after a job is done, might want to default to "Completed" status to 
filter out jobs that have been marked completed. 

Scheduling Grid Line Defaults (1-5) 
This option allows the ability to select the information to display as a company-wide default on 
the Scheduling Grid screen.  Click the down arrow next to each field to choose the appropriate 
information.   
 
During setup, it is a good idea to select something for the Schedule Grid Lines 1-5 default 
values.  These values can always be changed later and the view may be edited while in the 
Weekly grid, however remember that these default value fields determine how the jobs are 
displayed when opening the scheduling grid screen. If nothing is entered in these values and 
they are set to type Global or Assigned, the lines will have to be manually changed from order 
number/reference number each time.   

If these options are set to the type User, the user will not have to go to system options to 
change their default, changes can be made on the grid to update the default setting.   

 
 

Options 
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Show Jobs / Show Crews 
This sets the default setting for this filter on the Weekly Scheduling Grid.  The most common 
setting would be to leave it on "All Jobs / All Crews," which defaults to showing every provider 
and every job.  To see only the jobs that are scheduled, hiding every provider that is not working 
that week, choose "All Jobs / Scheduled Crews only."   
 
The best way to decide which filter to use is to go to the grid and pull up a week where many 
jobs are scheduled, test the various filters, and decide which one would be most handy. 
Regardless of the default set in this field, the filter can be changed for viewing and printing on 
the fly in the grid. 
 

Display Crew Availability Dots on Select Crew Screen 
Setting this to yes will turn on the color coded dots that display whether the crew is already 
booked or fully booked for the day in question. A black dot will still be displayed for days crews 
are off or unavailable.  This option has been added for those users who are looking for an 
increase in speed. 

Display Material Status Delta on Grids: 
 Setting this to yes will display the material status indicators on the detailed grid. This refers to: 
material status triangle color coded icons ( ). 
 

Refresh Grid when it gains focus:  
In version 11.1, a change was made so that each time the Grid Screen was clicked on after 
leaving it open and therefore it gained the focus in windows, it automatically refreshed. This 
refresh updated any changes in information made to the grid by any workstation, but it also took 
the user to the top of the file.  Some clients only want to refresh using the refresh button.  Set 
this to yes to automatically refresh.  

Select Grid to Display:  
Choose one of the options. 
 

Field Definitions  

Reference: the information in this field is determined by field 
mapping. See Field Mapping for details.  
User Defined Job Number: from the customer order  
Job Time Slot vs Job Time Slot Start End Times: Job time 
slot lists the name of the slot along with the times. 

 
Job Day: example Day 2 of 4 
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Detailed  

 
 
Simple 
This option condenses the view which is especially helpful when crews have multiple 
jobs per day or jobs that are on multiple days. 
 

This grid also has a short cut move job feature.  
 

 
 
 

 

Work Tickets  
>Utilities>System Options>Schedule Pro>Work Tickets>Work Ticket Footer 
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Work Ticket Footer   
This button opens a screen to enter a message that will print at the bottom of the Work Ticket 
that can be printed from Schedule Pro.  This is Store Code specific.  For a store code for 
commercial jobs and a store code for residential jobs, it is possible to have separate footers on 
the work tickets for each of those store codes. 

 

This work ticket can be used in place of the Order Entry work order. The labor 
dollar amounts cannot be encrypted on the work ticket, but are optional for printing.  

Setup Menu 
Schedule Pro>Utilities>Set Up 
 

 
Figure: Set Up Menu 

Change Stores  
Schedule Pro>Utilities>Set Up>Change Stores 
This screen allows selecting a current store code for scheduling.  For most users, this will never 
need to be adjusted manually.  The store code will always be the code of the last job scheduled 
unless manually changed. 
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The “current” store code selection is user specific.  One user can be set to schedule for store A 
and another schedule for store B (see System Options).  The GREEN checkmark shows the 
store that is currently selected for this user.  The current store is always in view on the Status 
Bar at the bottom of the Schedule Pro screen. 
 

 
 

Installation Depots  
Schedule Pro>Utilities>Set Up>Installation Depots  
This screen allows adding and editing Installation Depots.  An Installation Depot is a way to 
group crews, usually defined by a location that is their home base.  An Installation Depot could 
also be a second string of subcontractors that are only used when necessary.  Whatever the 
configuration, each warehouse location should be entered into Schedule Pro as an Installation 
Depot, if it has its own unique group of crews.  A crew can belong to only one depot in the 
system.     
 
Each RFMS Store Code must have at least one depot assigned to it.  Each Store Code can 
only be related to one Primary and one Secondary (backup) depot, so it is best to keep the 
number of depots to a minimum where possible. One depot can be assigned to multiple store 
codes, if appropriate. So, the “best practice” here is to have one or two depots at most per Store 
Code. It is not necessary to set up multiple depots if there are not multiple groups of crews. 
There is a way to assign crews to jobs from store codes unrelated to their depot, but it is 
considered a “work around.”   
 
The lower portion of the Installation Depots setup screen displays the automatically calculated 
capacities or allows for viewing and editing the manually entered capacities for each job type 
the depot can install for each day of the week.  A note on the tab will indicate which calculation 
option is being used. The ability to enter values on this screen is only available the Manually 
Entered Depot Capacities option on the System Settings Capacities is selected (see System 
Settings–Capacities).   
 
 
To enter a depot click on "Installation Depots" from the Main Screen, then hit the Insert button 
(the Green Plus), and type in the name of the depot.  If only using one group of crews, just 
name the depot the store name, and then tab over and type in the location.  Otherwise use 
name and location to specify how crews are divided.  
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Once the depot has been entered, hit "Associate Store Codes" at the top of the screen to pull up 
a list of RFMS Store Codes.  For any store codes to schedule, highlight the record, and hit the 
Edit button, then choose the appropriate Depot from the list created in the Primary Installation 
Depot column.  To associate a Secondary Depot, which is optional, choose a different depot in 
that column.   
 
For example, with two locations that are about 45 minutes drive time apart.  Set up a depot 
labeled "A Installers" and a depot named "B Installers", then set up your A store with a Primary 
Depot of "Anaheim Installers" and use the B crews as a backup for that store, entering "B 
Installers" as a Secondary Depot. 
 
For two locations that are too far apart to use each other's depots as a backup, just set them up 
with one depot each, i.e. A store has "A Installers" as a Primary and b store has "b Installers." 
 
If you just have one store code with one group of installers, Quality Carpets can just have 
"Quality Installers" as Primary. 
 
If you have one location, you can set up "In-House Installers" as primary and "Subcontractor 
Installers" as secondary for all of your store codes, and so on. 
 
 

  
 
If the manual method is selected in System Settings, then the capacities of each Installation 
depot must be entered for each product and day of the week that applies.  For example, only 
ceramic tile technicians are dispatched from Installation Depot One.  If so, only enter capacity 
amounts on the line(s) that reference ceramic.  The others would be left at zero.   
 
The Installation Depot Active Crews tab is a view-only information tab in which all of the 
crews are listed for the highlighted installation depot along with the highlighted crew’s available 
work days and capacities. 

  

 

Installation Depots - Associate Stores 

 
This button allows linking or associating each store with a primary and secondary Installation 
Depot.  This allows control of which depots and, thus, crews can be used for scheduling out of 
each store location.  An installation depot must be associated to a store code in order to 
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schedule jobs for the installation depots associated crews.  A depot can be linked to more than 
one store. 

 Each store code entered in RFMS displays on this screen automatically. If a store 
code needs to be added, that must be done in RFMS. 
 

 
1. Click the Associate Stores button.  The Relate Installation Depots to Stores screen 

appears. 
2. Double-click in the Primary Installation Depot column on the line for the store code to 

which the depot will be associated. 
3. Click the down arrow. A pick list appears that contains all the depot records already 

added.   If an Installation depot is not in the list, exit this screen and add the depot before 
continuing.  Select an Installation Depot name from the list. 

4. If there is a second depot that needs to be associated,  do the same in the 
Secondary Installation Depot column. Otherwise, leave the Secondary Installation Depot 
column blank. 

5. Click Exit to save the changes. 
6. Continue for each store code.  Remember, all store codes must have a depot associated 

to it before a job can be scheduled for that store code. 
7. If this store code is normally used at this workstation, click the Set as Current Store 

button.  A Green checkmark indicates the default store. 
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Crews  
Schedule Pro>Utilities>Set Up>Crews 
View, add, edit or delete crews from this screen.  
 
Crews should be added after Depots and Job Types have been set up.   
 

 
Viewing Crews 

Update Status for All Crews based on Worker Information File 
If  crews were initially entered by pulling the crew in from the Worker Information File (which is 
recommended – see Crew Information) and the information, like name or address, or phone 
number(s) changes, click the Update Status for All Crews based on Worker Information File 
button to refresh Crew information in the Schedule Pro.  This will NOT change the “Crew Name” 
field, but will update “RFMS Supplier / Provider” as well as contact information. 

Filters 
These filters can help narrow the view to find certain types of crews.  They can be used in 
tandem.  For example, narrow down to just view “Active” crews (Status) in one depot (Depot) 
who install “Carpet” (Job Type).   

Filter by Crew Status   
This will default to “Active” so that any old, “Inactive” crews will be filtered out of this view when 
the screen is first opened.  To view Inactive crews only, select “Inactive.”  To view ALL crews, 
regardless of status, select “ALL”. 

Filter by Installation Depot   
For most users, this will default to “ALL,” and it will not filter the list.  If the system option is set to 
filter to a specific depot, it will filter to show only crews in that depot.  The F8 button can also be 
clicked to view a list of depots, and select one to use as a filter, so the list can be narrowed 
down to one depot.   

Filter by Job Type   
For most users, this will default to “ALL,” and it will not filter the list.  If the system option is set to 
filter to a specific job type, it will filter to that job type.  The F8 button can also be clicked to view 
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a list of Job Types, and select one to use as a filter.  If a job type is selected, the list will only 
display the crews who have capacities for that job type. 

Crew Name 
To search for a certain crew name, type the first few letters of the crew’s last name in the white 
search crew name field and click “Tab.” 

Add/Edit Crews 
To add a new crew, click the insert button and follow the instructions on the Crew Information 
screen.   To edit an existing crew, highlight the crew name and click the edit button to open the 
Crew Information screen (or double click the crew that to edit).   
 

General Information – Crews 

 
 
Figure Crew Set Up screen 

 

RFMS Associated Supplier/Provider   
Though this is not the first field on the screen, it is the first that should be entered.  Click the F8 
button, and then choose either “Supplier” to pull from the RFMS Supplier file or, more 
commonly, “Provider” to pull from the RFMS Human Resources Worker Information File.   

 
 
To use the Create Provider Records feature of Schedule Pro now or sometime in the future, it is 
best to add crews by first pulling the record in from the Worker Information or the Supplier File.  
This will tie the crew to the record used to pay them.  Provider records cannot be successfully 
created for crews that are entered without importing.  To enter a crew manually, just fill in Crew 
Name, Depot, and any other desired information 
 

 The Provider box must be checked in the Provider record in the Worker 
Information File for the Providers to show up in the list.  (Active and Scheduler boxes must 
also be checked.) 
 
Double-click the desired Supplier/Provider to select, and it will fill in many of the Crew fields. 
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Crew Name   
This field will auto-populate from the RFMS Associated Supplier/Provider selection, but can be 
edited afterward.  For example, a provider named Theodore, is known as Ted, change the Crew 
Name to Ted, and this will appear throughout the schedule, while the provider records will still 
get created using “Theodore.” 

Crew Description & Crew Nickname 
These fields are optional and will not appear on any reports or many screens.  Use these to 
note any nicknames or the primary type of material this crew installs. 

Installation Depot  
Click the F8 button to choose an installation depot from the list.  A provider can only be 
assigned to one depot.  

Crew Status 
Click inactive for a crew who cannot be deleted because jobs have been assigned to them but 
should not show on the selection list.  
 
 

Web Orders 
 

Current Address  
This field will auto-populate from the RFMS Associated Supplier/Provider selection, but can be 
edited afterward.   

AVAILABLE WORK DAYS 
Check each day of the week the crew is available to perform installations. The Available Work 
Days information is taken into consideration during the actual scheduling procedure and 
determines if a crew is available for a specified day or not.  It also determines whether that 
crew’s capacities are counted in the depot capacities for that day. 
 

 Crew Capacities Tab 
To edit a crew’s capacities, highlight a crew in the top half of the Crew Setup screen, and then 
edit the corresponding “Daily Qty Limit” for the job type(s) to add or change for that crew.  In this 
example below, the crew can do either 1,000 SF of Carpet OR 350 SF of Ceramic or 8 HRS of 
Special Services, or he could do a combination of those things, and his capacities would be 
reduced by the percentage of the Daily Quantity Limit used by each job scheduled.  
 

 
 
This daily quantity limit, first says that this crew does this type of work at all.  If the limit is “0” for 
carpet, for example, the provider will not be offered as a carpet crew on the “Select Crew” 
screen.  It also assigns that crew’s daily capacity for that job type as well as adds that amount to 
that provider’s depot’s daily quantity limit for the job type. 
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Optionally a “Max Jobs per Day” for each job type can be added, though any messages relating 
to the Max Jobs per Day are generated from the system-wide generic Max Jobs field located in 
X>Utilities>System Options>Schedule Pro>Capacity Settings>Maximum Jobs per Day per Crew 
 
Last, and optional, is the Skill Level field.  Assign a “Skill Level” for each crew for every job type 
that crew installs. This field is a drop-down list that pulls from the Skill Levels list defined in 
Setup-Skill Levels.  These will show when selecting a Crew from a pop-up screen.  For 
example, if someone is a Master carpet installer, but a Novice at vinyl, note that and anyone 
scheduling them will know to try to use them on carpet, but use them as a backup vinyl installer. 
 

 Crew Contacts Tab 
In the Crew Setup screen, enter additional contact information.  It is not required, but could 
assist later if contacting the Installation Company or individual with questions about scheduling 
a job.   
 
Single-click a crew name to select.  Then, click the Crew Contact tab.  Click the insert button to 
add a Contact.  Fill in First Name, Last Name, Title, and Phone Numbers. Tab between fields to 
enter or edit information. 

  
 
As many contact names as needed for each crew may be entered.  For example, the crew may 
be an outside company each person who would perform installations under that company could 
be entered. 
 

If multiple contact names are entered, highlight one contact and click the Main 
Contact button to select the name of the individual who is the main contact person. A list of 
Crews and their contacts can be printed from the Report Menu. 
 

Crew Information Tab 
This is a convenient way to view information from the crew general information screen, and 
cannot be edited here.  

Time Off  
Schedule Pro>Utilities>Set Up>Time Off 
The days off scheduled for each crew can be added, deleted and viewed from here.   
 
In the Weekly Grid, a day off will be noted with a black dot 

 
 
In the Select Crew screen, a day off is noted with a black dot next to their name: 
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Scheduling Time Off for an Individual Crew 
To enter a new Scheduled Time Off date, click “Add to Schedule”.   Then, on the pop-up screen, 
select an Installation Depot from the F8 pop-up list.  Then, select a Crew from the second F8 
pop-up list. Add a Start Date and an End Date, and then click “Add to Schedule” in the top-right 
corner of the pop-up screen.  This will add the day(s) off to the schedule. 
 
A message will display indicated the day off was successfully added to the schedule.  
Enter an additional day off or click exit when finished.  

Scheduling Time off for all Crews 
To enter a new Scheduled Time Off date, click Add to Schedule. Then, on the pop-up screen, 
leave the All Depots & All Crews and All Crews checkboxes checked. Add a Start Date and an 
End Date, and then hit Add to Schedule in the top-right corner of the pop-up screen. This will 
add the holiday to the schedule. 
 

Viewing Scheduled Time Off 
This screen has a few filters, like many of the other screens in Schedule Pro.  If a day off is 
missing, check the filters first.  The Date range will default according to the system options 
setting. This will be filtered to “Specific”, which is one day, defaulting to today, “Range”, which is 
two weeks, defaulting to today and the next two weeks, or “All”, which does not filter by date.  A 
single depot and/or crew can also be used as a filter. 

Job Types  
Schedule Pro>Utilities>Set Up>Job Types 
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Figure Schedule Pro Job Types 

While an order in RFMS may have several material lines, in schedule pro they all make up a 
single job.  For Example, a carpet installation job may include the Carpet, Pad (Cushion), and 
Carpet Installation.  
 
These Schedule Pro Job Types are also used for filtering and reporting.   Each Job Type added 
will create a new Job Type Tab for tracking capacities on the calendar in the Schedule New 
Jobs screen. 

 
  
For the example above, enter a job type of Carpet Installation and associate the RFMS product 
codes for Carpet, Pad (Cushion), and Carpet Labor as a group.    
Job Type:  Carpet Installation 
Includes:  
RFMS Product Code for Carpet:  01 
RFMS Product Code for Pad (Cushion):  04 
RFMS Product Code for Carpet Labor:  81 (deduct capacity product code)  

 
Figure Carpet Installation Job Type with Associated Product Codes 

A type of unit must be assigned to each job type.  Only lines with that unit type can function as 
"Deduct Capacity" lines.  For example, if with "Hardwood" as the Job Type and the Units as 
"SF," any lines that fall into the Hardwood job type that are entered in LF, such as Stair Nosing 
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lines, will not deduct from the installer capacities even if they are marked as deduct with the 
green check mark.  To have trim pieces deduct, they’ll need to be in their own job type that’s by 
the LF or PC. 
 

To setup job types and associations, do the following: 
 

Adding the Job Type 

  Click the insert button.  The cursor will be positioned on a line at the bottom of the Job 
Type column. Type a name describing this product or group of products.  For our example, type 
Carpet Installation. 
 
Press the TAB key to move to the Units field.  Type the appropriate unit of measure for this 
product.  This should be the same unit of measure (i.e. EA, SF, LF, and SY) that used to 
enter most of the lines for this type of work in Order Entry.  Because the setting for unit of 
measure can be different for individual users, this setting will override the user setting for 
scheduling making the unit of measure consistent in scheduling for all users so that capacity 
calculations can be done.  The unit type should be two characters. 
 
The new job type is added to the list with the next available TAB order assigned to it.  See 
setting the tab order. 
  

Associating the Job Type to Products 

From the Job Type screen, click the Associate Job Types button.  
Double-click in the Job Type column for the desired product code. Using the down arrow select 
the job type from the list.  These are the job types already entered on the previous screen.  
Select the job type that applies to this product code.   Product codes which are not associated 
with a job type will not show on the list to be scheduled. 

Designating the Deduct Capacity Product code 
The last step is to designate which items in the group should be deducted from what a crew or 
depot can install in one day (capacities).  Single-click the product code and then click the 
Deduct from Capacities button.  A green checkmark will appear in the left column on the 

Product Code Line.  
 

 
This will only affect jobs scheduled from this point forward. 
 
When scheduling, only the line item quantities whose product code has the Deduct from 
Capacities green check mark will be deducted from the crew and installation depot capacities.    
 
Typically, the quantities would be deducted for the carpet material.  In this situation the 
quantities for the Pad (Cushion) and labor should not be deducted also. There can be situations 
where it will be more effective to use the labor product codes for deducting from capacities. 
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If a product no longer needs to be the deduct capacity product for this job type, click the  
button.  This will only affect jobs scheduled from this point forward. 

Associating a Color to a Job Type 
Job types can also be color coded to make viewing easier on the weekly grid and schedule new 
jobs tabs. Darker colors are not recommended, as they will make the text difficult to view. 
 
Highlight the job type, and then click the associate color button. When the choose color box 
appears; click the desired color or chose define custom color.  When the color is chosen, click 
the ok button.  
 

 

Tips for Using Job Types 

• Carpet & Vinyl - When associating Product Codes Carpet (01) and Sheet Vinyl (02) a 
Job Type with either SF or SY Unit Types must be selected.  If a SY Job Type is 
associated with the Carpet Product Code 01 then Schedule Pro will show RFMS Line 
Items for Carpet Product Code 01 in SY regardless of the user setting for other areas of 
RFMS.  If a SF Job Type is associated with Carpet Product Code 01 then Schedule Pro 
will show RFMS Line Items for Carpet Product Code 01 in SF regardless of the user 
setting for other areas of RFMS.  This is the same for the Sheet Vinyl Product Code 02. 

 

• A built-in Job Type called Miscellaneous can be assigned to Product Codes for items 
such as Trim, Underlayment, etc. so they can be shown on a customer order without 
affecting the capacity settings.  The Miscellaneous Job Type can be used for services 
that should not affect capacity settings and are not associated with a particular type of 
installation (removal, re-check, etc.) 

 

• A built-in Job Type called Unreferenced can be assigned to a product code.  This is the 
default setting if a product code is not assigned to a job type in Schedule Pro.  Any line 
items containing an unreferenced product code cannot be scheduled and do not affect 
the capacity settings. 

 

Setting the Tab Order 
 Each Job Type added will create a new Job Type Tab for tracking capacities on the calendar in 
the Schedule New Jobs screen.  The tab order set here is used on the schedule new jobs 
screen.  
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The TAB order is also used when adding temporary lines during the scheduling of a job. The 
orders in which the job types appear in the drop-down list can simply the line entry process.  To 
set the tab order in the Schedule New Jobs screen, click the Sort By Tab Order tab. Highlight a 
Job Type, then click the up or down arrow to move it forward or backward in tab order.   

Skill Levels  
Schedule Pro>Utilities>Set Up>Skill Levels 

The Skill Levels area allows creation of a list of different skill levels for crews.  This is optional.  
When a crew record is created, a skill level can be assigned to the crew that specifies the 
competency of installation ability (i.e. novice, master, etc.) for each job type that crew installs.  
For example, a crew can be a “Master” carpet provider, but a “Novice” vinyl provider.  If this 
feature is used, create the list of skill levels on this screen, then go to Crews to use this list to 
modify Crews. 

  
Inserts a new Skill Level record. 

  
Changes the highlighted record. 

  
Deletes the highlighted record. 

The Skill Level is assigned to the Crew in the Crew Information screen: 
 

 
 

The Skill Level displays during the Scheduling Process, in the Select Crew pop-up screen: 

 
 

See Related: Setting up Crews  

Job Status  
Schedule Pro>Utilities>Set Up>Job Status  
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This screen allows setting up the Job Status list.  Each job will have a job status, which helps to 
filter jobs.  
 

 

 

• When Schedule Pro is first installed, there will be 10 default Job Statuses already in 
place.  Any of them may be edited or deleted.  To do so, highlight the proper Status and 
click the Edit (yellow pencil) button or Delete (red x) button. 

 

• To add a status click the insert button, then type the status description in the blank field. 
 

• The status order as appears when using F8 to select the status on screens throughout 
Schedule Pro can be changed. Highlight a status then click the up or down arrow to 
move it up or down in order.   

 

• Although an unlimited number of statuses are possible, it is recommended to keep this 
list as simple as possible to make the filtering useful.  

 

• Once  statuses are decided on, each user can have a default “Job Status” set in system 
options be assigned when they schedule a new job (“In Progress,” for example) and 
another default status to filter on when loading the Create Provider Records screen 
(“Completed,” for example). 

 

• Once assigned to the scheduled jobs, these statuses will show in Order Entry, in the 
“Status” field for the soonest, or most recent jobs scheduled for that Order. 

Job Time Slots 
Schedule Pro>Utilities>Set Up>Job Time Slots  

 
This screen allows creating a list of Job Time Slots to be used to quickly assign time frames to 
the jobs.  On each job, a Start and End time can be manually edited, but most users prefer to 
use Time Slots for speed and consistency. 
 
The first three time slots are hard-coded in the system.  Their names however can be edited.  
They are “MIXED” which is an all day job (8:00 AM to 5:00 PM), “MORNING” which is from 8:00 
AM to Noon, and “AFTERNOON,” which is from 1:00 to 5:00 PM.  To edit the name on these 
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three, simply highlight the line, click the Edit (yellow pencil) button and type the desired name. 
Duplicate time slot descriptions are not allowed.  
 

Based on System Settings (General Tab), jobs can default to a Morning or 
Afternoon time slot based on the Work Order Notes in order entry. 
 

 
 
Time slot descriptions can be added or deleted from this screen.  Fifteen user-defined fields are 
included.  In the example above, Time Slot 4 has been “user defined” as an 1st Day.  
 
To edit the fifteen user-defined time slots, highlight the line, click the Edit (yellow pencil) button 
and type the desired Time Slot Description, then click Tab and edit the start time, tab again to 
edit the end time.  
 

In order to make scheduled times more flexible an option to not limit times entered to those on 
the time drop list has been included.  

If the box is checked, picking from the 30 minute intervals in the drop list for Start and End times 
for each slot is required. If the box is not checked, any time can be typed in.   

 
Figure: Edit using Drop List 
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Figure: Using Time Slots 

Tracking Tables 
Schedule Pro>Utilities>Set Up>Tracking Table1 or 2 

This screen allows creation of a list of descriptions that can be assigned to scheduled jobs and 
used to group jobs for tracking reports.  Each job that is schedule can be assigned to one of 
these tracking descriptions on the Schedule New Jobs screen (or, later, in the Edit & Complete 
screen.)   
 
The name of the Tracking Table 1 or Tracking Table 2 button can be changed from 
>Utilities>System Options>Schedule Pro>General>Prompts which will rename the “Tracking 
Table 1 or 2 button on the Setup screen.  In this example, Tracking Table 2 was renamed to 
“Service Outcome”.   
 

Adding/Editing a Tracking Record 
Click the Insert button to add a new record.  Type a description of the tracking category.  Press 
Enter to save the record.  
 
Click the Edit button to change the name of a tracking record 
 

 
 

Click the change active status button to toggle a description between 
active and inactive. Active records are marked with a tag icon. Inactive records will not show in 
the drop down list when assigning tracking data to a job.  
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While a description which is assigned to a job cannot be deleted, it can be made inactive 

Using the Tracking Category 
Click the Schedule New Jobs button. 
In the lower right portion of the screen, press the F8 next to one of the tracking fields.  The 
tracking categories already entered appear.  Click one of the categories to select it.  By 
assigning this scheduled job to one of these categories, reports can be printed using the 
category as a sorting option. 
 

 
 
 
 
 
 

Order Entry Field Mapping 
For multiple stores, it is possible set the work ticket footer and field mapping from order entry on 
a per store basis.  Highlight the store to set then click the Map Fields button  
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Map Fields from Order Entry to Schedule Pro  

 
This is where editing the field mapping that is used when a job is pulled from Order Entry to 
Schedule Pro is done.  These settings are store code specific. To use this Set Up for all 
stores, just click the button.  
 
The defaults are listed below, and put the Sold-To Order Header information in the Customer 
field in Schedule Pro and the Ship-To Order Header Information in the Ship To information in 
Schedule Pro.  Although this screen WAS created to edit mapping if needed, it is recommended 
to keep it as close to the default as will work, as the reports are built with this data setup in 
mind. 
 

Customer:  Default Setting = Sold to First Name, Sold to Last Name 

Reference: Default Setting = BLANK OR PO Number (This refers to the Order Entry Header PO 

Number) 

Job Number:  Default Setting = RFMS User Defined Job Number, often known as the 

"Sidemark" 

Ship to Name:  Default Setting = Ship to First Name, Ship to Last Name 

Ship to Address 1: Default Setting = Ship to Address 1, Ship to Address 2 

Ship to Address 2: Default Setting = BLANK 

Ship to City:  Default Setting = Ship to City 

Ship to State: Default Setting = Ship to State 

Ship to Zip:  Default Setting = Ship to Zip 

Telephone 1: Default Setting = Telephone 1 

Telephone 2: Default Setting = Telephone 2  

Use this Setup for All Stores:  Click the button to copy these settings to all stores in the 

system.  
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Maintenance 
Schedule Pro>Utilities>Maintenance  

Reset Depot and Crew Capacities  
This menu item triggers a routine that refreshes job types, crews, and capacities throughout the 
program.  So much of the program is built on data that is user defined that if a job type or crew 
or crew capacity is added or edited, it’s a good idea to click this button to make sure those 
changes are reflected in the Schedule New Jobs screen and all throughout the program.  This 
can take a few minutes, depending on the amount of data in Schedule Pro and on hardware 
speed. 
There will be three confirmation messages, click ok on each of these. There could be several 
minutes between the updating capacities message and the reset successful message.  

   

Purge Completed Jobs  
This menu item allows for a periodic purge of jobs from Schedule Pro.  Most users prefer to 
leave a backlog of jobs in the system for at least a year to have the ability to run long-term 
tracking and performance reports and to trace back through the service history of a job.  
However, after a few years, it is possible to purge some of the older jobs.  Pick the most recent 
date to keep, and click the button to purge all jobs that were scheduled BEFORE that date. 
 
This is the place to purge old jobs from schedule pro.  If the System Settings screen has not 
been password protected, the PURGE SCHEDULED JOBS button probably should be 
protected. 
 

 
Figure: Maintenance Purge Screen  

Scheduled Jobs Must Be Completed Prior To   
Choose a date in this field and click the PURGE SCHEDULED JOBS button to remove all (job 
costed) jobs that fall before (not including) that date. 

Calculator  
Schedule Pro>Utilities>Calculator or F2 Click Here for Details 

 

https://rfmsinc.zendesk.com/hc/en-us/articles/202172978-Calculator
https://rfmsinc.zendesk.com/hc/en-us/articles/202172978-Calculator
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Calendar 
Schedule Pro>Utilities>Calendar or F8 at any date field 

With all date fields in RFMS, hit the D key to fill in today’s date, type in a date, use the up and 
down arrows to move the date one day at a time or click F8 to bring up the calendar and then 
choose the date. 

Click here for details.  

 

Order Entry/Schedule Pro Integration 

Schedule Pre Related Options in RFMS  

 Best Practice: Require an estimated delivery date on customer orders.  

The following options must be checked  

>Utilities>System Options>Order Entry>Providers>Integrate Provider’s Earnings, must be set to 
yes.  
 
>Utilities>System Options>Order Entry>Order Entry>Automatically Post Estimated Delivery 
Date 
This option by default is set to yes (in RFMS Order Entry).  If this option is left as is, the Order 
Header Estimated Delivery Date will update based on scheduled line dates.  For example, a job 
has lines scheduled for completion on May 1st and lines scheduled for completion on May 5th.  
In April the Order Header Estimated Delivery Date will display, as May 1, 20XX.  On May 2nd, 
the Order Header Estimated Delivery Date will change to May 5, 20XX and stay so unless there 
are other dates later than that in the order (assuming nothing is added to the order). This switch 
is recommended in order to update the Order Header Estimated Delivery Date. 
 
These options control a portion of the integration between RFMS Order Entry and Schedule 
Pro.  
  
>Utilities>System Options>Order Entry>Schedule Pro>Schedule Pro Button on Orders Browse  
 

 
Figure Pressing Schedule Pro Button on Orders Browse will 

Pressing Schedule Pro Button on Order Browse  
 
The option labeled "Schedule Pro Button on Orders Browse" refers to the Schedule Pro button 
on the Customer Order and Claims toolbar: 
  

 
 
Select one of the following options for interaction with the Schedule Pro module. 

https://rfmsinc.zendesk.com/hc/en-us/articles/201877827-Calendar
https://rfmsinc.zendesk.com/hc/en-us/articles/201877827-Calendar
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Do you want alerts to be created from order entry so that a centralized office can schedule all 
jobs or do you want jobs to be scheduled as they are created in order entry? 

Create Schedule Pro TO BE SCHEDULED Alerts  
Selecting this option will create a Schedule Pro alert for the highlighted order when the 
Schedule Pro button (located on the toolbar) is clicked. An alert indicator will be placed to the 
right side of the Order Number field. The alert icon is the same as the Schedule Pro icon, with 
one small exception - the alert will display in red. If the Order Entry people have set an 
Estimated Delivery Date for the order (in the Order Header), this can become the suggested 
schedule date, depending on the system settings.  Once the job has been scheduled, the alert 
disappears and a regular Schedule Pro icon will appear. Note "Display Alerts on Order Entry 
Browse" is not selected, the red Schedule Pro icon will not display.  However, the alert has still 
been created.  To check these alerts go to the Schedule Pro module and click the button that is 
labeled Order Entry Alerts.  

Open Schedule Pro for Selected Order 
Selecting this option will allow immediate access the Schedule Pro module from the Customer 
Order Screen.  Click the Schedule Pro icon (located on the toolbar) and the Schedule Pro 
module will open to the highlighted order and ask to add that job to the schedule or view existing 
scheduled items associated with that job.  If the Schedule Pro was already open on that 
computer, it will bring the screen up just as it was left.  Use this selection only if not creating 
alerts. This setting is only meant to be used by someone who should have access to adding 
jobs to the scheduler or editing them.  
The link between Schedule Pro and Order Entry has been changed so that when the Schedule 
Pro button is clicked only the Schedule New Jobs Screen opens rather than the whole 
Schedule Pro program.  

 
Once Schedule Pro is opened this way, it is available from the Order Entry>Windows Menu, 
until Order Entry is closed.   
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A simple version of the Schedule New Jobs Screen is available.  The selection of which to use 
is made in >Utilities>System Options>Schedule Pro>General>Job Schedule Screen from Order 
Entry. 
 
 
 
 
 
 
 
 
 
 
 

Alert Options 
>Utilities>System Options>Order Entry>Schedule Pro>Create Schedule Pro Alerts.... 
 

 
Figure: Order Entry SP alert Options  

 

Create Schedule Pro Alerts for Edited Orders (checkboxes) 
These options determine whether to create an alert when someone changes an order in Order 
Entry AFTER it has been scheduled.  We recommend leaving this box checked to "Yes" as to 
make sure changes made after scheduling don't fall through the cracks.  If each choice below this 
line is left to "Yes" an alert is automatically created, thus turning the regular Schedule Pro icon to 
red in the Order Entry browse until the alert has been dealt with on the scheduling side, for the 
following scenarios: 

Order Voided 
Order Line Deleted 
Order Line Added 
Order Style, Color, or Units Edited 
Order Quantity Edited 
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Order Status Set to Cut or Reserved  
(This creates an alert every time material is received for a job that is already scheduled, 
and for many users, should be left off, as it creates so many alerts, it can be difficult to 
keep up with them.) 

The Schedule Pro users can browse through these alerts, make appropriate changes, sometimes 
at the push of a button (to remove deleted lines from a scheduled job, for example), and then 
delete the alerts so the people in the Order Entry screens will be able to see that the icon has 
gone back to normal, thus the scheduled job is fine. 
 

Display Schedule Pro Alerts on Order Entry Browse 
Selecting this option will display the red/green Schedule Pro icon to the right of the order 
number field on the customer order Line.  If this option is deselected, the alert icons will no 
longer display.  However, alerts may still be accessed by clicking on the Order Entry Alerts 
button in the Schedule Pro module.  
This also controls whether or not the schedule icon will display next to orders which have lines 
scheduled.  
 
 
 

Schedule Pro Icons in RFMS Order Entry 

Alerts 

                    
This icon indicates that the job has been marked To Be Scheduled.  There is a corresponding 
“To Be Scheduled” alert in Schedule Pro.  

  
This icon indicates that there is an alert other than a “To be scheduled alert,” related to the 
order. Indicating that an order has been changed since the job was scheduled, and as a result 
there is an Order Entry Alert in the Schedule Pro.  Once the alert has been deleted from 
Schedule Pro (whether or not the discrepancy has been fixed,) this icon will change to the 
schedule icon. 

Scheduled  

  
This icon indicates that the line item or job has already been scheduled.   
 

Important Considerations for Customer Orders 
The estimated delivery date on the job header or the job lines can be very important as 
schedule pro uses this date to place the job on the schedule, if not included the date will default 
to today’s date.  

RFMS Worker Information 
RFMS Accounting>File>Human Resources>File>Worker Information 

Schedule Pro integrates with Order Entry when entering a provider record to keep the pay 
status associated with installers or suppliers in the RFMS application.   

The following information must be set in the provider’s worker information file in RFMS Core 
Human Resources.  
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A worker must be active to be available in Schedule Pro.  If marked, Do Not Pay status in 

Human Resources, this will carry over to the provider record entered.  

Check the Provider box for all workers who will provide services that will be posted as a cost 

against jobs in the Provider’s module of Order Entry. This could apply to all types of workers. 
This box must also be checked for this worker to be available in Schedule Pro for jobs to be 
scheduled to them.  

Checking this box makes the pay status and Do not Accrue boxes later on this screen active.  

 

Selecting the Scheduler option will allow this particular worker to be available in Schedule Pro 

to schedule jobs.  Selecting this box plus the Provider box allows a worker to be available for 
jobs.  

 

Passwords 
Password protect any button, field or screen in Schedule Pro. 
 

Schedule Pro utilizes the same password functionality as the RFMS programs.  Any button, 
except the F8 buttons, can be password protected based on the security levels set in RFMS. 
Change into Set Password Mode by pressing the F6 key.  The top level password is required to 
do this.    
 
Log in with the TOP Administrator Password. Go to the screen that contains the button to 
protect.  

1. Press the Ctrl-Alt-F6 key.  
2. Click the button to protect.  
3. A list of all passwords will show.  
4. Select the password level to assign to this button and click the Select button.  
5. Then click Ctrl-Alt-F6 to exit password mode. 
6. To view more information on using Passwords, refer to the help found in the Order Entry 

module of the RFMS core product. 
7. If using “Password on Entry Only” in the Core RFMS, Schedule Pro will use that setting 

as well, which allows the ability to enter a password upon opening the program, and then 
allows entry to all authorized areas without reentering a password.  In this case, a user 
will only be prompted for a password if the area they are attempting to enter requires a 
higher level password than the one used to log in. 

If using Enterprise Manager, it will apply to Schedule Pro, just as it does to any 
other RFMS product.  Set up a group of Schedulers, and assign permissions accordingly. Edits 
on various tables in Schedule Pro may also be tracked. 
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File Menu 

Scheduled Jobs 
Schedule Pro>File>Scheduled Jobs 
View or edit scheduled jobs from this screen.  The bottom section gives the scheduled lines for 
the job highlighted in the top portion.  Jobs listed here are determined first by the default 
settings in >Utilities>System Options>Schedule Pro>General>Category: Default Filters. Use the 
find button to locate other jobs.  To go back to the default settings while still in the screen, use 

the reset button.  The clear filter button   will set the find to include all records.  
 

Multiple Day Jobs 
If a job is scheduled for more than one day, a BLUE Plus sign is displayed next to the Start 

Date.  
 

 
Figure: Scheduled Jobs Screen 

Tool Bar 
Tools available here can be customized so all options listed may not be visible on the screen. 

 
Add: Click the insert button to schedule a new job.  
 

Edit: Click the edit button to change the highlighted job. (This is the equivalent to the old edit 

and complete feature). Click here for details on the changing scheduled job screen.  
 

Delete: Click the delete button to delete the highlighted job from the schedule.  
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Tagging:  Tagging jobs on this screen is used only for mapping. Lines can be tagged on the 

highlighted jobs for printing on work orders or work tickets if this option is chosen.  All other 
functions apply to the highlighted job. When a line is tagged, a printer icon is shown next to it to 
indicate this.  

Print work order:  Highlight the jobs to print and then click the print work order button  

The options here are the same as printing a work order from Order Entry.  Click here for details.  
 

 
Figure: Confirm Work Order Printing 

Print schedule pro work ticket: Highlight the jobs to print and then click the print schedule 

pro work ticket button  
 
Clicking this button will print a work ticket for the highlighted job. Choose a single line by tagging 
it. The ability was added to tag lines by clicking in the left column on the record in version 
10.5.6. Choose the information to be included on the ticket by checking the boxes in the print 
options screen.  If two crews are scheduled for one job, as of version 10.5.6 they will both be 
included on the work ticket.  

https://rfmsinc.zendesk.com/hc/en-us/articles/206084007
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Display Print Options  

 
Figure: Print Options Screen. 

Work Order Areas 
Checking this box will print the order line areas from the RFMS Work Order on the work ticket. If 
there are multiple RFMS work order line areas for one order line, they will all be printed on the 
Schedule Pro work ticket.  

Work Ticket Footer 
Checking this box will print the work ticket footer as set up in >Utilities>System Options> 
Schedule Pro>Work Tickets>Work Ticket Footer on the work ticket.  

Print Signatures 
Checking this box will print signature lines on the work ticket.  

Print Labor for Each Line  
Checking this box will show the dollar amount  

Use Provider Record Rate if Exists 
 Checking this box will use the Provider Record Rate 

Print Labor Total  
Checking this box will show the total dollar amount 

Print Balance Due  
Checking this box will show the dollar amount due on the order.  

Combine Split Lines Back Together  
Checking this box will take a multiple day job and combine the information to only be 
printed on day one.  

Print for Tagged Lines Only 
Checking this box will require the lines to print to be tagged on the view scheduled job 
screen.  

Preview 
Checking this box will allow viewing the work ticket on the screen before printing.  
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Output to CSV 
Checking this box will allow the work ticket to be sent to a csv file which can be used like 
an excel file.  

Save to pdf History Table 
Checking this box saves a pdf copy of the work ticket which can then be viewed or 
printed later.  

Email PDF 
 Checking this box will allow a PDF of the Work Ticket to be emailed. 

Scheduler Job Notes 
Checking this box will print the header notes from Schedule Pro on the work ticket.  

Scheduler Line Notes 
Checking this box will print the line notes from Schedule Pro on the work ticket.  

Order Entry Custom Notes 
Checking this box will print the custom notes from the RFMS Header on the work ticket.  

Order Entry Internal Notes 
Checking this box will print the internal notes from the RFMS Header on the work ticket.  

Order Entry Line Notes 
Checking this box will print the Line notes from the scheduled RFMS order line. 

Work Order Custom Notes 
Checking this box will print the custom notes from the RFMS Work Order on the work 
ticket.  

Work Order Line Notes  
Checking this box will print the order line notes from the RFMS Work Order on the work 
ticket. If there are multiple RFMS work order line notes for one order line, they will all be 
printed on the Schedule Pro work ticket.  

Work tickets can also be printed for a group of jobs from the Quick Schedule Screen.  

Map Tagged Jobs 

 
Clicking this button will connect with Bing maps with the tagged location(s) marked on the 
map.  The system asks if you would like to use the current store as the starting location, 
otherwise a starting point can be manually entered on Bing. Print the map from Bing. When 
done use the OK button to close the web site. 
 

Scheduler Job Notes 

 
Clicking this button will allow adding or viewing notes added to the job header from 
Schedule Pro. If notes are present a note icon will show next to the invoice number.   
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View All Notes  

 
Clicking this button will allow viewing all related notes including CMM remarks. A note icon will 
show next to the invoice number only if schedule pro notes are present.   

Using Find for a More Streamlined Search  

 
If a find is applied, any searches will only look at the records from within the filtered list.  Check 
the find setting if an expected record is not found. 

Find by Install Date 
Specific  Looks at a single day 
Range   Looks at a group of days.  Enter the Start and End date 
All   Looks at all days 
Cancelled Only This gives jobs with no dates and times. See Cancelled. 

Other Finds 
All other Find options on this screen can be used by themselves or as a combination.  
They give very powerful methods of working with and searching for scheduled jobs.  To 
include all records within a specific category, leave the field black.  Otherwise, click the 
F8 button to select a specific Find from the corresponding list. To remove data from a 
field click the Clear button.  

Notes about using Finds 
If Finding by Job Type, only line items for the specific material will display.  If a job does 
not have any lines items of that material, the job will not display at all. The default Store 

Code is applied automatically.  To view all store codes, click the clear button.  
 

Remark Type 
The remark type was added to the options for finding scheduled jobs in, Scheduled Jobs, Quick 
Schedule, Quick Edit, Weekly Grid and Create Providers. Only scheduled jobs with the selected 
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remark type will be found.  Remarks can be added to scheduled jobs in Client Management or 

via the Client Management Remote Actions Button  while in Schedule Pro.  (Version 11.1)  

To go back to the default settings while still in the screen, use the reset button.  The clear 

filter button   will set the find to include all records.  

Search   
Click the Search button to search for scheduled jobs by specific fields within the find set above. 
Click the reset button to clear this Search.  

 

 

Mail Options  

 
 

 
 

PDF History   
Click the pdf history button to view all reports printed and saved to pdf history for the 
highlighted record.  

Options 
Interoffice Mail: Click this button to send an internal 

RFMS mail message regarding the highlighted record  
 

Email: Click this button to send a blank email with the 
signature information added during set up.  
 

*Email Using Template: Email templates can be set 

up for Client Management Retail and Commercial users.  
 

*Mass Email Using Template: From Client 

Management Retail or Commercial, Tag multiple 
prospect or customer records then send a template 
email 
 

Cancel:  Exit without any action  
 

* See CMM New features for details.  
 

http://www.rfms.com/Support/Documentation/V11CMM.pdf
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Client Management Module  
Click the CMM button to bring up the CMM remote actions screen and add a CMM action or 
relate a CMM record to this record.  

Edit a Job  
Schedule Pro>File> Scheduled Jobs>Edit Button or Scheduled Jobs>Edit>Change 

Highlight a job in Scheduled Jobs or on the grid, and then double click to change the record.  

 
Figure: Changing scheduled job screen 

Tool Bar 
Tools available here can be customized.  

Email Job Schedule  

From the Changing a Scheduled Job screen, click the email button.  This creates an 
email through Outlook.  The outlook message can then be edited or have other files attached.  
The email address is pulled from the order associated with the scheduled job. If an email 
address was entered in system options it will automatically be carbon copied on the email.  

 
Figure: Sample email generated from Schedule Pro 

View Alerts  

 
Click this button to view the Order Entry Alerts & Tracking Notes Screen. 
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Add Alerts  

 
Click this button to add a tracking note.  

View Order 

 
Clicking this button allows the order information related to the job to be viewed. 

 
Figure: View Order Detail 

 

 
 
The next buttons allow viewing the specific notes related to the job.  If permission is set in 
system options notes in RFMS can be added or edited here also.  
 
Buttons that are labeled Scheduler Notes or Scheduler Line Notes may be added, edited or 
changed in the Schedule Pro Program without special permission. When a note is added to a 
job, the button letters turn Green and a note icon is displayed in the far left column. 
 

Installation Depot & Primary Crew 
The store number is displayed in the upper right hand corner of this area. This area includes 
fields for information in addition to that which was entered on the schedule screen. 
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Installation Depot 
If the depot is changed and does not match the current crew, a message will display warning 
that the crews will be deleted.  

 

Primary Crew  
If initially assigned to a crew, that crew will show here.  A crew can be assigned or changed on 
this screen, but the crew and the depot must match.  

Secondary Crew 
Picking a crew here would be for display purposes only, to actually assign quantities and show 
on the grid use the Split lines tool.   

Warehouse Prep 
To be available as a choice, the person must be checked in HR active and scheduler but not a 
provider.  

Available on these reports: 
Daily Schedule by Date (Landscape) 
Daily Schedule by Date & Time (Landscape) 
Daily Schedule by Crew (Landscape) 
Daily Schedule by Order (Landscape) 
Material Status Report with PO Information (Landscape) 
Job Summary Report – Detailed 1 (Landscape) 

Job Status 

Job Status  
Click the F8 button to choose one of the statuses created during the set up process.  

Follow Up Employee 
To be available as a choice, the person must be checked in HR active and scheduler. 

Follow Up Description  
Free form; does not show on any reports.  

Tracking Table1 and 2 

User Defined 1 & 2 

Occupied  
If this is included in order entry the information will be pulled from the order header. In addition, 
if this is changed in schedule pro, it will update the order header.  

Pre Walk Date   
Enter the date.  

Dates   

Job Cancelled or On Hold  
If the job is cancelled, the system will place a check mark in this box.  
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Cancel Job  
If a job is cancelled and not rescheduled, click the cancel job button which will remove the 
scheduled dates, but keep any associated alerts. Cancelling will also prompt adding a tracking 
note. A warning message will show to prevent accidental cancellation.  Filters have an option to 
search for cancelled jobs. When rescheduling the jobs, the lines will show zero quantity.  
 

 

Scheduled Date/ Time/ Time Slot   
Scheduled information can be edited here. The start date can be edited here, but adding days to 
the job must be done using the Split lines tool. When changing the number of days on a job, do 
not change the “End Date” of the job.   

Actual Date Time  
This allows recording the scheduled information vs the actual. This method is not recommended 
because if used the actual on the lines must be edited each time it differs; most people simply 
edit the scheduled information.  

 

Stop  
10 Characters available. Some clients use this for routing jobs. Several jobs may be scheduled 
for the same time slot then prioritized by location or importance using the stop field.  

Skip 
The scheduled information can be edited here.  

Edit Information  
Date Entered 

This information is automatically collected by the system.  

Scheduled By 

Can be automatically entered if so set in Utilities>System Options>Schedule 
Pro>General>Default User otherwise either type the appropriate name or choose it using the F8 
button.    For a person to be included in the pick list, they must be checked as a Scheduler in 
RFMS Human Resources. 
 
Edited By 

Can be automatically entered if so set in Utilities>System Options>Schedule 

Pro>General>Default User otherwise type this information in.  

Reason for Edit  

This can be a required field. Set in Utilities>System Options>Schedule 

Pro>Scheduling>Warning Messages. 
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Order & Customer Information 
Most of this information is brought over from the original order or claim.  If necessary, the 
information can be edited here.  If the information that needs to be changed is on the order or 
claim, it is best to change it in RFMS Core.  Then click the Update Info Button to make the 
changes in Schedule Pro. If the field mapping is changed, clicking this button is required to 
apply the changes to each previously scheduled job.  

Edit Job Lines  

 

Deduct Number of Crews   
For use with manually deduct # of crews. Shows the number deducted and will editing that 
number here.  

Job Total Dollars 
Job Type Total $ - Total sale dollar amount for the deduct capacity products. Line Units have to 
match the Job Type Units.  
 

 
 

Line Information 

  
 
Click the green plus button to add a temporary line.  

Click the pencil button to change the highlighted line. 

Click the red x button to delete the highlighted line from Schedule Pro; it will not delete the line 
from the order.  

Click the Mail button to send an interoffice mail message about the highlighted scheduled job 
line.  

Click the green check button to make the highlighted line a deduct capacity line. This is 
restricted to items with the same unit of measure as the job type. 

Click the green check button with a red mark to make the highlighted line not deduct from 
capacity. 

 

When a line is untagged, the green check (Deduct Capacity Line) will be removed.  When it is 
retagged, the green check (Deduct Capacity Line) will be put back. 
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Split Lines Tool 
This tool allows job lines to be split between either crews or days.  
 

 
 
Split lines will allow determining the number of days, and even the percentage to go to each 
day. (To schedule a Tuesday & Thursday job, do 3 days with 50% on Tuesday and 50% on 
Thursday, then "Apply Split" and it will show as T / Th on the grid, and show that crew as being 
free on Wednesday.)  It is key that after setting the number of days, the percentages add up to 
100, and then click "Apply Split." This screen can also be used to split jobs over multiple crews, 
not just multiple days.  
  
The grid itself looks at the lines on the job to determine the quantity it is attributing to each 
day.  So, it is key to split the lines, not just change the header dates. 
 
Then, hit “Apply Split” to affect the change, and save the job as normal. 

Use this tool to split a job between crews 
First, schedule the job. (NOTE:  If a “Secondary Crew” is added without splitting the lines, it will 
not show on the grid or many of the reports for that secondary crew.) 
 
In the Split Lines screen, up to 10 total crews can be added, and a percentage of the overall 
quantity of the job assigned to each.  The percentages must add up to 100.   
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Change Job Line Crew: Click the button to change the crew on the highlighted line only.  

RFMS Order Line Notes: Click this button to view only notes on this line which were added 

to the order line in RFMS Core.  

RFMS Work Order Line Notes: Click this button to view only notes for this line which were 

added to the work order in RFMS Core.  

Scheduler Line Notes: Click this button to add or view notes on this line 

Job Type Totals 
This shows the total by Job Type of deduct capacity lines.  The dollars = selling price. 

Schedule New Jobs 
Schedule Pro>File>Schedule New Jobs  

 
 
Scheduling new jobs is easily done using the Schedule New Jobs function.  From this screen, 
select an RFMS Customer Order, assign a crew and pick an available day for installation.  The 
Schedule Pro program can determine the availability of crews by skill level, depot and daily 
capacities based upon data entered in the configuration areas of each category.  Refer to those 
sections of the user guide for detailed instructions on setting up the Schedule Pro software.  
 

To clear all the fields and reset the screen click this button. 
 

Clicking this button displays the scheduling information for a different store. 
 

 
Figure: Change Store Screen 

 
On the Change Store Screen, high light the store to change to then either double click or click 
the select button.   
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Crews Available for Scheduling (The Calendar Area) 

Reset Calendar Days  

 
Click to move the calendar forward or backward a month or week at a time. 

 
 
At the top of the calendar, a dropdown menu is displayed that match up with the job types 
entered in the Setup area.  Clicking on each tab displays the individual capacities for each job 
type.  The ALL CREWS tab shows the depot capacities combined. The tab order is also set in 
system settings. 
 

• The date currently being worked with is changed to a BLUE color. 

• Clicking on a calendar date box changes the Start Date for the job currently being 
scheduled. 

The Crew Capacity is shown for each day for easy determination of which dates are available 
for scheduling.  With the All Crews tab selected, the capacities are a total of all product types to 
show total capacity for the depot.  Otherwise, clicking on each job type tab displays the capacity 
for that job type alone.  If viewing capacities by quantity instead of by crew as set in 
>Utilities>System Options>Schedule Pro>Capacity Settings> View Installation Depot Capacities 
By, the capacity for the All Crews tab is shown in percentages. 

 
Crew Capacity Color Code Legend: 

Green   No jobs scheduled 
Blue   Less than 75% used 
Orange  Over 75% used 
Red   100% booked or overbooked (can be negative numbers) 
Black   Crews do not work on that day 

 

Select on the bottom of the calendar whether to view in house or subcontractors.  
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 If scheduling most without selecting a crew, be aware that the specific job type 
tabs are not always going to be accurate.  A job scheduled without a crew will deduct capacities 
from job type tabs that are being scheduled and from the ALL CREWS tab but it will not deduct 
anything from other job types.  Since the crew is unknown, it is not possible to determine how 
the other job type capacities would be affected.  For example, if a crew is selected for a carpet 
job and they install carpet and vinyl, then both the carpet and vinyl capacities will be reduced 
(the crew can’t install both at the same time).  But, if a crew is not selected for a carpet job, only 
the carpet capacities will be reduced.  That is because without a crew selected, the system can’t 
forecast the abilities or capacities of future crew assignments. Pay close attention to the ALL 
CREWS tab, it always considers the overall picture. 
 

Enter Job Information  

 
 
This area is where the customer order information is selected or entered.  In addition, lines for 
each product to be installed are either entered as a temporary line or tagged (if the lines exist on 
the RFMS Order already). 
 

Job Type: 
Click one of the option buttons.  
Set the default under Utilities>System Options>Schedule Pro>Scheduling>Order Type 

 
• RFMS Original: Choosing this option allows access to customer orders entered in the 

RFMS Order Entry module.  The following information will be brought over from the 
RFMS order if present: Customer, Salesperson, Phase, Tract, Block, Lot, Job Number, 
and Ship to Information, Telephone numbers. 

 

• RFMS Claims: Choosing this option allows scheduling a job entered as a claim by 

using the F8 key. The following information will be brought over from the RFMS Claim if 
present: Customer, Salesperson, Phase, Tract, Block, Lot, Job Number, and Ship to 
Information, Telephone numbers. 

 

• Customers: When this option is selected, choose a customer name from the RFMS 
Customer list by using the F8 key, or type in the customer information. The Order # field 
will be grayed out with this option.  
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  Jobs may not be scheduled across stores.  A workstation set for store 1 may not 
pick a customer order from store 2, etc.  The store code within Schedule Pro must be changed 
to work with orders from other store codes.  The current store code can be changed from this 

screen by clicking on the change store button.  
 

RFMS Order #   
For RFMS Original or RFMS Claims, type an order number in or use the F8 key to display the 
list of available orders or claims.   
 

The F8 key brings up the Select RFMS Order to Schedule Screen.  

 
 Figure: Select RFMS Order to Schedule Screen 

View All  
Click the view all button to see notes for the highlighted record. 

Search 
Click the search button for additional search options. 

 
 Figure: Find Records Screen 

Filters 
Narrow the choices using the choices in the filters.  
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Tabs 
The search fields on each tab can also be used to narrow the choices. Clicking the tab 
will order the list information by the tab information. 

 

Order Lines 
This section shows all the lines on the highlighted invoice. Lines which are already 

scheduled are marked with a symbol.  
 

Once the correct invoice is located, click the button to work with this order.  

 
Customer  
If a customer order or claim is used, this will be filled in.  A customer name may be typed in or 
use the F8 key to bring up the list of available customers.   

 
Figure: Select customer screen 

Highlight a customer record and click the select button.  
 
 

Other Fields 

Reference  
This information is set up in Utilities>System Options>Schedule Pro>Schedule Pro>Reference 
Prompt or type in the desired information.  

Salesperson  
If information is from an order, this will be filled in or Use the F8 key for the list to choose a 
salesperson.  
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Phase/Tract/Block/Lot 
If information is from an order which has this information, this will be filled in or the information 
may be typed in.  Orders may be searched and filtered based on this information from the 
RFMS Order Section.  

Deduct # of Crews 
This is only visible when Schedule Pro is set to Manually Enter Number of Crews to Deduct 
in system options.  

Job Number (Definable field name) 
If information is from an order which has this information, this will be filled in or the information 
may be typed in. 

Ship to Information  
If information is from an order which has this information, this will be filled in or the information 
may be typed in. 

Telephone Numbers  
If information is from an order which has this information, this will be filled in or the information 
may be typed in. 

Job Lines   

 

• If scheduling by RFMS Original or RFMS Claim, lines on the selected order are listed in 
this area.   

o Tag the line items to schedule using the Tag buttons (click a line and then click 
the Tag button or left click next to the line).  The only field that can be edited for a 
RFMS Order Line is the quantity. 

 
o A temporary line may also be inserted.  A temporary line is used by Schedule Pro 

to calculate crew and installation depot capacities but is not related to a customer 
order in Order Entry.  For each Temporary line added enter a Job Type, Style, 
Color and Quantity.  Temporary lines will have a line number starting with T.  
Temporary lines are automatically tagged and automatically have a deduct 
capacity status.   

• Lines on a customer order that have already been scheduled (either completely or 
partially) display this icon in the left column.  This feature is useful if customer order lines 
are scheduled at different stages as the job progresses.  

 

• Line Items can be scheduled more than once to split the quantity between different 
crews.  To schedule a partial quantity just change the amount in the quantity column.  
The next time this RFMS Order is selected for scheduling the quantity will reflect only the 
amount left to be scheduled.   
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• If scheduling by Customer Name, then temporary lines will need to be added in order to 
schedule the job.  At a later date the job can be edited.  An RFMS Order with line items 
can be associated to the job and then the temporary line items can be deleted if desired. 

 

• Lines that display:  All statuses except for Job Costed.  Unless Allow RFMS Job Costed 
Line Items to be Scheduled is checked on the General Tab in the System Settings then 
job costed lines will also be available for scheduling. 

Select Dates and Times 

  
 
SELECTING DATES OR DISTRIBUTING INSTALLATION ON THIS SCREEN ONLY WORKS 
FOR NEW JOBS.  Once a job is added to the schedule, dates or distributions on this screen will 
not take effect, click the Edit button or double click to change the highlighted job.  

# of Days 
Enter a number or use the up/down arrows to increment the number.  

Start and End Date 
These fields work concurrently with the Calendar and are always synchronized.  For a multiple 
day job, the percentage to be installed for each day can be edited.  Initially, the installation is 
evenly distributed over the number of days set but can be customized to fit the job.  If set in 
Utilities>System Options>Schedule Pro>Order Entry>Base Schedule Pro Install Date....and the 
estimated delivery date is included in order entry the start date will be pulled from the estimated 
delivery date from the order header.  If not start date will default to today’s date.  

The end date cannot be manually entered; it is calculated by the number of days and whether or 
not skip days are included.  

Time Slot 
Use the F8 key to choose the time slot.  These choices are set in Set Up>Job Time Slots. If this 
is included in order entry the information will be pulled from the order header. Also if this is 
changed in schedule pro, it will update the order header.  There is a system option setting to 
choose between using the Job Time Slot Start & End Times or the First Job Line Start & 
End Times.  

Start and End Time 
Although these can be edited to be different from the time slot, this is not recommended. The 
start and end times are not used for determining crew or depot availability.   
 

The specific start & end times are only stored on the lines. This is used to fine tune the jobs if 
needed to have different specific times for all or some lines.  If the times on the lines have to be 
changed to something other than the header "time slot" times, you CAN have the "first job line 
start & end times show on the grid by choosing this selection on the grid. You can also show 
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"First job line start & end times" in the list of jobs that appears on the Schedule New Jobs 
screen by setting system options. 
 

However, because many reports and other screens use the time slot description from the 
header, it is recommended to approximate the times of the job as best as possible using the 
time slots provided. 

Skip Sat/Sun/When Crew Off 
These check boxes will default from system options. To schedule on one of these days, 
uncheck them for the system to actually schedule on those jobs.  For example a crew may not 
normally work on a Saturday, but will for this job.   

Distribution 
Click the Distribute Evenly button to spread the installation evenly for each day of the job.  This 
only applies to jobs that are scheduled for multiple days and only when scheduling a NEW job.  
The daily distribution amounts can be changed as needed but must always equal 100%.   

Stop  
10 Characters available. Some clients use this for routing jobs. Several jobs may be scheduled 
for the AM slot then prioritized by location or importance using the stop field.  Stop can also be 
seen & edited on the quick schedule screen for routing / dispatching purposes 

 Stop Available on these reports: 
Daily Schedule by Date (Portrait) 
Daily Schedule by Date & Time (Portrait) 
Daily Schedule by Crew (Portrait) 
Daily Schedule by Order (Portrait) 
Jobs Edited 

Select Tracking Information 

 
 

Use the F8 key to access the drop down listing for these fields  

Job Status 
These options are set up in Set Up>Job Status.   

Tracking Table 1/2 
This field allows assigning a tracking category to this job.  Press F8 to access the tracking data 
listing.  The tracking fields are used to categorize installations. This user defined information is 
set up in Set Up>Tracking Table1 & 2  

Scheduled By 
This is a required field.  Can be automatically entered if so set in Utilities>System 
Options>Schedule Pro>Default Values otherwise either type the appropriate name or choose it 
using the F8 button.    For a person to be included in the pick list, they must be checked as a 
Scheduler in RFMS Human Resources. 
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User Defined 1 & 2  
This information is set in Set Up>System Settings>Fields & Report Set Up. If used, select the 
appropriate radio button for this job.  

Select Crew  

 
This is where a crew is selected for the job.  By default, the No Crew box is checked. The ability 
to schedule a job without picking a crew is user defined in >Utilities>System Options>Schedule 
Pro >Scheduling>Warning Messages>Crew Required This feature is useful when scheduling 
days or weeks ahead to save the date but crews are not assigned until right before the job is to 
start.  However, to select a crew while scheduling the job, click the F8 button to access the crew 
listing screen.   

The columns on the select crew screen are adjustable, so that more of a particular column may 
be viewed.  Once adjusted, this setting will remain until manually changed. Adjust by hovering 
over the column divider until the double arrows appear, then right click and hold, moved to the 
desired width, and then release the mouse button.  
 

 
 

  
When all the information is entered for the job, click this button to add the job to the schedule.  
The software will automatically analyze to see if there are any potential capacity conflicts and 
display a warning if there are.  If the job is added to the schedule the calendar capacities will 
automatically be refreshed.   
 

Jobs Scheduled for Selected Depot and Day 

 
 
This area shows the jobs scheduled for the selected calendar date and current installation 
depot. This list will show jobs scheduled from all stores using this installation depot. The sort 
order of the jobs can be changed by clicking on the various tabs.  

Edit or Delete  
In addition to this quick overview, jobs can be edited by double-clicking on the scheduled job or 
deleted by highlighting the scheduled job and clicking the delete button. If a job is edited, the 
calendar will reflect those changes after returning from the Edit Job screen. 

DRAG & DROP to Change Installation Date 
If enabled on this workstation, it’s easy to move a job from one date to another from this screen.   
Drag and drop a job from the Jobs Scheduled list to another date on the current calendar view. 
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No matter which date is grabbed in the original line, for example day two of the job, the new day 
it is dropped on will be the new start date.  
 
For dates not on the current calendar view, use the Yellow Folder as a "holding bin" to move a 
job to a date that is not shown on the current calendar view. 
  

1. Click the job to be re-scheduled in the Jobs Scheduled list.  While holding down the left 
mouse button, DRAG the cursor onto the Yellow Folder.  Release the mouse button.  

 
2. The job information is now transferred and can be viewed in the Yellow Folder. 
3. Move the calendar forward or back using the arrows until the desired installation date is 

in view on the calendar. 
4. Click the job information in the Yellow Folder.  While holding down the left mouse 

button, DRAG the cursor to the new desired installation date on the calendar. 
5. Release the mouse button.  The job is now moved to the new installation date. 

Quick Schedule 
Schedule Pro>File>Quick Schedule  
 
Jobs listed here are determined first by the default settings in System Options>Schedule Pro 
with the category Default Filters. 

 Use the find button to locate other jobs.  To go back to the default settings while still in the 

screen, use the reset button.  The clear filter button   will set the find to include all 
records.  The remark type was added to the options for finding scheduled jobs in, Scheduled 
Jobs, Quick Schedule, Quick Edit, Weekly Grid and Create Providers. Only scheduled jobs with 
the selected remark type will be found.  Remarks can be added to scheduled jobs in Client 

Management or via the Client Management Remote Actions Button  while in Schedule Pro.  
(Version 11.1)  

 
The Quick Schedule screen allows viewing all jobs for a single day as well as: 

• Adding jobs to the schedule from Order Entry based on the Estimated Delivery Date in 
the order header. See Batch Scheduling from Order Entry  

• Viewing scheduled job Entry totals for a selected day for each job type. 

• Editing multiple jobs simultaneously to: assign or change crews, assign or change time 
slots or stop numbers, or change the values for "User Defined 1 or 2." 

• Deleting multiple jobs from the schedule simultaneously. 

• Updating Scheduled jobs directly from Order Entry. 

• Batch printing RFMS Work Orders for a day's scheduled jobs  
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When the Quick Schedule screen is first opened, it will show all jobs scheduled for today's date.  
Use the Find Function to narrow the jobs to view. All the jobs that meet the filter criteria will be 
listed in the browse below.  Use the tabs at the top of the browse list to sort and search the list.  
 
The grey box at the top left of the screen will display the Total Number of those Jobs Scheduled 
that meet the criteria listed and a few other totals, such as the User Defined 1 Values and the 
count of jobs that are scheduled for each of the two Primary Time Slots, as defined in 
Utilities>System Options>Schedule Pro>Scheduling> Quick Schedule Display Time Slot Totals 
1 and Quick Schedule Display Time Slot Totals 2. 
 
Many of the column widths in this browse list are adjustable. 

Batch Scheduling from Order Entry  

 
 
This feature allows importing ALL jobs from Order Entry that have the selected Estimated 
Delivery Date, usually today or the next working day.  To use this feature, the Estimated 
Delivery Date must be entered in the order header in Order Entry.  This date will become the 
scheduled date.   
 
To add one more step on the Order Entry side to be sure that only jobs that are ready to be 
scheduled are added, Train Order Entry people to mark a job "To Be Scheduled" using the 
Schedule Pro button in Order Entry when it is ready to go.  Then on the Schedule Pro import, 
select only jobs that have the desired Estimated Delivery Date AND are marked with the To Be 
Scheduled Alert rather than adding all jobs with the correct Estimated Delivery Date.   
 

   The Estimated Delivery Date field can be renamed in System Options. If there is 
no field named Estimated Delivery Date in the order header, go to System Options and find out 
what the field has been renamed. 
 
Before starting to batch schedule, check Utilities>Schedule Pro>Order Entry>Automatically Tag 
the Order Lines to be sure that it is set to "All Lines" or "Deduct Capacity Lines Only" so the 
system will know which lines to add to the job when it automatically adds it to the schedule.   

 
Click the batch schedule button, and the following screen will appear: 
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Select a Store Code and a Depot Name from the F8 lists.  Be sure the Scheduled By field has a 
user name. If using the To Be Scheduled Alerts safeguard described above, check the box 
labeled Order Entry 'To Be Scheduled' Alerted Orders Only.  Then Click "Schedule" to add the 
jobs. 

 
• Only RFMS Original Orders and those for the selected store will be scheduled.   

• The routine will not check the Scheduling Warning Messages as set in system options  
 

The following fields will be set based on defaults set in 
Utilities>System Options>Schedule Pro>General 
 Category Prompts:   
 

• Tracking Table 1 Description 

• Tracking Table 2 Description 

• User Defined Field 1 

• User Defined Field 2 

• Job Status 

• Deduct Number of Crews (If Enabled) 

• Scheduled By 

• Job Time Slot:  
 Utilities>System Options>Schedule Pro>General 

 
o Primary Time Slot 1 if ‘AM INSTALL’ entered in Custom Work Order Note 
o Primary Time Slot 2 if ‘PM INSTALL’ entered in Custom Work Order Note 
o Time Slot ID = 1 if no appropriate Custom Work Order Note 

Any "To Be Scheduled" Alerts for these jobs will be deleted.  Next edit the jobs by 
assigning crews, time slots and/or stops. 
 

Edit Scheduled Jobs  
Whether jobs were added to the schedule using the batch scheduling or scheduled one at a 
time in the regular Schedule New Jobs screen, they can be viewed, updated, and changed in 
the Quick Schedule screen. 
 
To assign a crew to multiple jobs for that day, tag the jobs to assign, and then select the crew 
from the Edit Primary Crew F8 button in the box surrounded by a teal border.  (NOTE:  If some 
of the tagged jobs do not belong to the same Installation Depot as the new Crew an error 
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message will be displayed and those jobs will not be changed.)  Then click the Change Primary 
Crew button.  
 

 
 
To change the Time Slot and/or Stop values for these or other tagged records, follow the same 
procedure until all jobs are assigned and scheduled.   
 
The values can also be changed for the User Defined 1 and 2 fields.  For instance, using User 
Defined 1 to note whether a job has been confirmed and all jobs for the day are set to "N" for 
that field, tag all the jobs for that day that have been confirmed, then select "Y" for that field in 

the blue box, and click the edit button.   

Deleting Jobs  
To delete an individual job, highlight the job in the browse box, then click the delete button.  A 
confirmation box will appear.  There is no need to tag the record for a single delete. 
 
If a group of jobs on a certain day have been added to the schedule in error, tag all of them on 
this screen, then click the button labeled Delete Tagged Scheduled Jobs.  Again, a 
confirmation box will appear. 
 
WARNING:  Use this feature carefully as there is no "undo" option for these deletes! 

Update Scheduled Jobs from Order Entry 

 
WARNING:  If not using the Batch Scheduling, this update feature may not be useful!   
 
If all lines for a lot are added into one order in Order Entry, then schedule multiple separate jobs 
in the Schedule Pro by job type, using the Update Scheduled Jobs feature is not recommended.  
Instead, use the Order Entry Alerts to update scheduled jobs to reflect changes that have been 
made in Order Entry rather than using this automated feature.  To see why, read on. 
 
This feature essentially auto-updates all jobs that have Order Entry Alerts.  Once a day is 
selected, click the button labeled Update Scheduled Jobs from Order Entry to change ALL 
scheduled jobs for that day to make the jobs match the order file as follows: 
Line Added:  If Utilities>Schedule Pro>Order Entry>Automatically Tag the Order Lines is set to 
"Deduct Capacity Lines Only," the Automatic Update will add any Deduct Capacity lines to the 
job that are not currently there.  If that setting is set to "All Lines," all lines that are in the order 
and not in the scheduled job will be added.   This update would only be desirable if all of an 
order is routinely scheduled in one job.   

• Line Deleted:  All lines that have been deleted from the order since the job was added to 
the schedule will be deleted from the schedule. 

• Line Edited / Line Qty Edited:  Any Product, Color, or Quantity information that has been 
changed for a line in the order will be changed accordingly in the schedule.   
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• Order Voided:  If an order was voided in Order Entry, it will be deleted from the 
schedule. 

• Once the update is complete, the Order Entry Alerts will be deleted for these jobs. 

This button does update ALL jobs for the day – tagging is irrelevant for this feature. 

 

View Daily Totals 

 
 
Clicking this button shows the daily number and quantity total for each job type as defined in 
Utilities>Set Up>Job Types. Each job type's amounts are showed in the unit of measure that is 
selected in the Job Types screen.  Carpet will be displayed either by the SF or by SY, 
depending the selection in Job Types, and Hardwood will be displayed by SF, and so on.   
 
If using batch scheduling for adding jobs for this day, the Daily Totals screen is a good way to 
check the total amounts scheduled against installation capacities for the business.   
 

 
 

This button shows ALL jobs for the day – tagging is irrelevant for this feature. 
 

Batch Print Work Orders 
Use this to print multiple RFMS Custom Work Orders or Schedule Pro Work Tickets for a 
selected day. 
 
In the Quick Schedule screen, tag all records, or just tag the jobs for which to print work orders. 
If some of the day's work orders have been printed and now wish to print the rest, tag the 
remaining jobs by clicking the button labeled Tag All Jobs with No WO Printed, then click the 
print button to print the remaining orders. 
 

 
 
If a RFMS Custom Work Order or a Schedule Pro Work Ticket is printed for a job through the 
Quick Schedule screen, a work order icon will appear in the browse box next to the order 
number.  
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The Custom RFMS Work Orders will not print temporary lines that have been added in the 
scheduled job but not added in the Order Entry module.  To print a simple work ticket for that 
type of job, do so in the View Schedules screen. 
 
To display print options check the display print options box, to save a step deselect this box. 
 Click the Print Work Orders for Tagged Records button.   
 

 
 
Choose whether to print an RFMS Custom Work Order or the Schedule Pro ‘Work Ticket’ will 
print. 
 

 
 

 
 

 
Access the RFMS Interoffice Mail system to send a message about the highlighted job, send a 
generic email or an email using a template built in the CMM program.  
 

 
Accesses the Client Management Remote Actions Screen for the highlighted order  
 

 
View the PDF history screen. 

Quick Edit 
Schedule Pro>File>Quick Edit 

This screen allows quick editing of previously scheduled orders. For example go to this screen 
at the end of the day and tag all the jobs with completed work orders and change the status of 
them all at once.  Another example is removing all jobs from one crew. 
 

Jobs listed here are determined first by the default settings in >Utilities>System 
Options>Schedule Pro>General>Category: Default Filters. Use the find button to locate other 



 

Version 19.0  85 
 

jobs.  To go back to the default settings while still in the screen, use the reset button.  The 

clear filter button   will set the find to include all records.   

 

 
First use the filters at the top of the screen to narrow the scheduled jobs list. Next use the tabs 
to change the sort order and further search. 
 
Tag the jobs to change.  
 
Click the F8 or down arrow button to the right of the field(s) to edit select the new values AND 
click the Change button.  
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Create Provider Records for Tagged Jobs 

 
 
A group of jobs can also be tagged to create provider records for them from this screen.  This 
might be done from this screen after the status is changed for completed jobs daily. Once at 
least one provider record is created for a job, the invoice number is highlighted in yellow. A 
message will also display when attempting to add an additional provider record.  

 

Daily Schedule Grid 
Schedule Pro>File>Daily Schedule Grid 
 
This grid shows scheduled jobs for one day at a time  

 
Figure: Jobs Daily Grid  
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Toolbar 

 Exit the Daily Schedule Grid. 

 Brings up the Schedule New Job screen.  
Select to use the full or simple screen in Schedule >Utilities>System Options>Schedule 
Pro>Scheduling Grid>Select Grid to Display  

 Edit the selected job.  

 Move back one day. 

 Search for a specific day.  

 Move one day forward. 

 Show Detailed Crew Information for the selected job.  

 Print Daily Job Schedule Reports. Simple or Detailed.  

 Use the find feature to find specific jobs or a specific crew. 

 Click the reset button to set the find back to default options as set in Utilities>System 
Options>Schedule Pro> Category Default Filter Settings.  

 Clear the find so all options are included.  
 

 Refreshes the grid to include recent changes.  
 

Multiple Jobs 
If multiple jobs are scheduled for the same time, the words multiple jobs will show on the 
display. Clicking the block will pop up a listing of the jobs. The multiple Jobs type must be 
checked for these to show. Because the daily grid is designed to be sorted by job (material) type 
if more than one type is scheduled for the same job, then that job will show as multiple jobs. The 
job type is displayed in the pop up window.  

Show Detailed Crew Information for the selected job 

A button has been added to show the Crew Information on the Daily Grid.  Click on a job to 

select it, click on the Show Crew Information Button.  The Crew Information screen for the 
crew on the selected job will pop up.  
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Reports 

Click the Printer button.  
Two reports are available from the Daily Schedule Grid.  
 

 
Figure: Simple Daily Job Schedule Report. 

Report Options 
Click the printer button to access the report options.  
  

 
The simple report is a one line per job listing. The detailed report is the same as the Daily 
Schedule Landscape Report from the reports menu.  
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Grid Display Settings 
The grid can show one line of information about scheduled jobs, choose this using the drop 
down list under Display Information.    

 
 
Next choose whether the grid will be divided into 30 minute or 1 hour intervals but selecting the 
desired option.  30 minute will give a more detailed time breakdown, but 1 hour will show a 
smaller grid.  

  
 

Set a start and end time for the grid.   
 
On the right hand side of the grid, choose the job types which will be displayed by checking or 
un-checking them in the list.  To include just a few job types, untag all and then choose those 
types.  
 
If a single job type will always be viewed, go to Utilities>System Options>Scheduling 
Grid>Primary Daily Grid Job Type and select that job type as the Primary Daily Grid Job Type.  
 
Doing so will enable a button on the screen with that job type as the name. Clicking the button 
will deselect all other job types, leaving the primary job type as the only one to be displayed.  

 
Figure: Daily Grid Job Type Options 

 

 

 

 

The choices are:  
Customer Name 
Customer Name/Tract/Lot  
Job # Prompt  
Job # Prompt/Customer  
Order Number  
Order Number/Tract/Lot 
Ship to Name 
 



 

Version 19.0  90 
 

Weekly Grid 
Schedule Pro>File>Weekly Grid 
 

This screen allows viewing scheduled jobs in a grid format for one week at a glance.  It is also 
possible to drag & drop to move jobs around with ease. 
 

Jobs with no crew assigned will be listed at the top of each grid. Depending on the amount of 
data, scroll bars may be needed to see all the information. 
 

The Grid has two views: Simple or Detailed.  

 
Figure: Detailed Grid 

 

 
Figure: Simple Grid 

Jobs with no crew assigned will be listed at the top of each grid. Depending on the amount of 
data, scroll bars may be needed to see all the information.  
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Changing to a Different Time Frame 
The buttons at the top of the screen allow moving forward and backward to view different dates 
or to move a job from one day to another. 
  
BUTTON DISPLAYS 

  Previous Month 

  Previous Week 

  Previous Day 

  Next Month 

  Next Week 

  Next Day 

  Search for Specific Day  
 

 
 
Here, as with all date fields in RFMS, hit the D key to fill in today’s date, type in a date, use the 
up and down arrows to move the date on day at a time or click F8 to bring up the calendar and 
then click the go to date button or hit enter. The grid will display with the date entered first.   
 

Filtering Records for a More Streamlined Search 
 

1. The default user grid setting can be set in Jobs listed here are determined first by the 
default settings in >Utilities>Schedule Pro>General>Category: Default Filters.   For 
example a User could default to seeing only jobs from their default store.  

2. Use the Find button  to narrow the jobs shown from the user defaults. If filter is 

applied, the grid view will only include the records meeting those criteria.  The 
button will turn blue if a find is applied.  For example, the user may want to temporarily 
narrow the view to see only jobs in the morning time slot.  
 
All filter options on this screen can be used by themselves or as a combination.  They 
give powerful methods of working with and searching for scheduled jobs.  To include all 
records within a specific category, leave the field blank.  Otherwise, click the F8 button to 
select a specific filter from the corresponding list.  
 
If filtering by Job Type, only line items for the specific material will display.  If a job does 
not have any lines items of that material, the job will not display at all.  To view all store 
codes, clear the store code field.  
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 Use the reset button to get back to the user defaults.  

 Use the clear button to clear even the user defaults and show all scheduled jobs.  

 Use the reset button to include changes to jobs which have happened while viewing the 
screen.  The screen also refreshes any time a change is made on the screen. 
 

3. Show Jobs/Crews  
Use this drop down list to limit the jobs displayed on the grid. 

 
 

a. Set the default value for this under >Utilities>Schedule Pro>Scheduling 
Grid>Show Jobs / Show Crews 

b.  All Jobs/All Crews: Includes jobs for which no crew is assigned. Includes crews 
to which no jobs are assigned. 

c. All jobs/Scheduled Crews only: Includes jobs for which no crew is assigned. 
Excludes crews to which no jobs are assigned. 

d. Crew Assigned/All Crews: Excludes jobs for which no crew is assigned. Includes 
crews to which no jobs are assigned. 

e. Crew Assigned/Scheduled Crews only: Excludes jobs for which no crew is 
assigned. Excludes crews to which no jobs are assigned. 

f. No Crew Assigned/All Crews: Only Jobs with no crew assigned. Includes crews 
to which no jobs are assigned. 

g. No Crew Assigned/No Crews: Only Jobs with no crew assigned. Includes no 
crews.  

4. Deduct Capacity Lines Only: Check this box to exclude jobs with no lines marked as 
deduct capacity.  
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Viewing Crew Information  
 
Double click a crew name to view a crew’s basic information. If the popup information is in the 
way, drag and move it on the screen.  
 

  
Figure: View Crew 

 

Grid Color Coding 
To the left of each job there will be a material status triangle color coded icon.  They are defined 
as follows: 

 

Red - None, Gen PO 
   Orange - On Order 
   Yellow - Reserved 
            Green - Cut, Staged, or Delivered 
            Blue - Job costed, Partial Billing 

 
To the right of the first line for the crew/day there will be a crew status icon.  This is the same 
icon that is displayed in the Select Crew for Job screen which displays the crew capacity for the 
day using the dot color coded icons.  These icons are defined as follows: 

 

  Red - 100% booked or overbooked 
  Orange - 76% to 99% booked 
   Yellow - 1% to 75% booked 
            Green - 0% booked 
            Black - Crew does not work on selected day. 

 

Printing the Grid 
Either grid may be printed for the seven days shown on the screen. To do so, simply click the 
button at the top of the Scheduling Grid that says, Print this Grid.  Printing landscape or legal 
gives blank space for notes.  
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Figure: Sample 7 Day Grid Report 

 
Figure: Sample Full Legal 

 

Grid Options  
Click the delete button to remove a job and its alerts from the schedule.  
 
Click the edit button to get to the edit screen. Double-clicking the highlighted job will also allow 
editing.  
 
Select a Date and a Crew by clicking in the corresponding box, and then hit the insert button to 
add a job. That Date & Crew will be pulled up in the Schedule New Jobs screen.  Now, add the 
job, tag lines, choose a time slot, and hit “Add” to schedule. See schedule new job screen for 
more details on scheduling  
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Moving Jobs 

To move a job to a different day in the current week: 
1. Click the job with the left mouse button. 
2. While holding the button down, drag the cursor to the new day. 
3. Release the mouse button and the job is moved. 
4. No matter which date is grabbed in the original line, for example day two of the job, the 

new day it is dropped on will be the new start date. 
 

To move a job to a different week or month: 
1. Click the job with the left mouse button. 
2. While holding the button own, drag the cursor to the YELLOW folder. 
3. Release the mouse button.  The job information appears next to the Yellow folder 

button.  The folder button changes to indicate the job is ready to be moved. 
4. Click one of the Navigation buttons to move to another day, week or month. 
5. When the new day is shown on the grid, click the Yellow folder and drag the job to the 

new day. 
6. Release the mouse button and the job is moved. 

 
Jobs moved into the Folder area are not moved from the schedule date until they are actually 
"dropped" into a new day.  If this screen is exited while a job is in the Folder, it will revert back to 
the original date 
 

Simple Grid Only 

Display Job Info  
 
The simple grid only displays one line of information per job, this is a quick way change the 
information shown.  
 

View Job Info  
 
Clicking this button gives more detail on the highlighted job.  

 
Figure: Job Information Screen 
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View All Job Lines   
 
On the simple grid, the View all job icon indicates that there are more jobs for the crew/day 
than are displayed.   
 
Clicking this button on any day shows all job lines scheduled for the same crew and day of any 
highlighted job.  
 

 

Move Job  
 

 
 
If a job is highlighted on the grid, the order number will be automatically entered; otherwise a 
number can be typed in.  A date must be entered or use the F8 button to access the calendar.  
To change the primary crew, use the F8 button to select a new crew from the list.  
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Orders Ready to Schedule 
Schedule Pro>File>Orders Ready to Schedule 

 

 
Figure: Orders Ready to Schedule Browse List  

Schedule Pro has had this function for quite a while, but it was with the alerts screen. It was 
relocated in version 11.2 to the file menu for easier access.  
 
These alerts represent customer orders that have NO Delivery Date or Estimated Delivery Date.   
It is a reference to see all jobs that have never been scheduled. 
 
Display RFMS Orders When- choose between:  
All Lines are Unscheduled 
Some Material Lines are Unscheduled 
Some Labor Lines are Unscheduled 
 
Display RFMS Orders when- choose between:  
All Material lines have a status of>>>  
At Least One Material Line has a status of>>> 
 For these two choose any combination of statuses 
Orders with Labor Lines Only (Status does not apply)  
 
Hide Material Only Jobs Check this if scheduling is done only via service lines. 
 
Clicking on Add to Schedule brings up the Schedule New Job Screen.  
 

View RFMS Order : Clicking this button allows viewing the order 
information related to the job. Details. 
 
Jobs filtered on the Search for RFMS Orders to Schedule tab can now be printed.  

Using the Orders and line options filter to the desired list, and then click the  Print Browse 
Button.  
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Figure: Sample Report 

 

Alerts 
Schedule Pro>File>Alerts 
 

 
This screen allows viewing and acting on ‘Alerts’ created in Order Entry and exported to the 
Schedule Pro module as well as tracking notes which are created in Schedule Pro. 
 
To create alerts, set up specific Order Entry Options:  
Utilities>System Options>Order Entry>Alerts>Display Schedule Pro Alerts on Order Entry 
Browse 
Alerts are meant as a way for the scheduler to find out about new jobs that need to be 
scheduled (To Be Scheduled Alerts) and/or things that have been changed in Order Entry for 
jobs that have already been scheduled.  Tracking Notes are a way to create a reminder for 
someone to follow up on some part of scheduling a job. 
 

Filters 
Filter through these alerts/notes by using Filters on the screen. 
 

 
 

Alert/Notes options  

All-All alerts and tracking notes 

All Alerts-Only alerts  

Orders To Be Scheduled  - these alerts represent orders from the Order Entry module that 

have been sent over to the Schedule Pro module, but have not been scheduled nor have had 
any changes made to them. Schedule Pro will prompt deletion of this alert when any part of the 
order is scheduled.  
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Orders Voided – these alerts represent orders that have been sent from the Order Entry 
module, but have now been voided in Order Entry. There is a button in the Alerts screen that will 
allow deleting any jobs from the schedule that have an “Order Voided” alert.  Clicking the button 
will also delete the related alerts. 

 
Lines Added - these alerts represent customer orders that have had lines added to orders 

AFTER the order has been scheduled and BEFORE the scheduled date has passed.  Note that 
the Product Code for the line is showing in the alert.  If this is for a product code not used for 
scheduling (supplies, sundries, for example) delete these alerts.  If it is a line to add to a 
scheduled job, do so (see below) from this screen and when returning to alerts a prompt will ask 
to delete the alert. 

 
Lines Deleted – these alerts represent customer orders that have had lines deleted from an 

order AFTER the order has been scheduled and BEFORE the scheduled date has passed.  
There is a button in the Alerts screen that will allow deleting these lines from the scheduled jobs.  
Clicking the button will also delete the related alerts. 
 

Lines Edited – these alerts represent customer orders that have had changes made to line 

information such as: Style/Item, Color/Description or Units in order entry AFTER the order has 
been scheduled and BEFORE the scheduled date has passed.  These are optional and are not 
used by most users.   

 
Lines Edited Qty – these alerts represent customer orders that have had changes made to 

line quantity in order entry AFTER the order has been scheduled and BEFORE the scheduled 
date has passed.  These are among the most important alerts.  There is a button that will 
automatically update the corresponding line (by line number) in the scheduled job to the NEW 
quantity in Order Entry.  This auto-update will only work if the line hasn’t been split over multiple 
days or multiple installers in Schedule Pro.  When the auto-update is run, it will delete the alerts 
for any lines that it was able to change and leave the remaining alerts on this screen to be dealt 
with. 
 

Line Status Cut/Reserved- these alerts show when individual lines are changed to the “Cut” 

or “Reserved” line status AFTER the order has been scheduled and BEFORE the scheduled 
date has passed.  Alerting when material has been received for a scheduled job.  Most people 
DO NOT use these alerts, as the scheduler will be inundated with this information.   
 
See REPORTS for information on a report that will show any material lines that have NOT been 
received on jobs scheduled for a certain time period. 

 
Tracking Notes- Only Tracking Notes These are the only alerts that can be made in Schedule 

Pro.  They are notes that the scheduler can make as a reminder to follow up with a customer on 
scheduling at a set time in the future.  These can be printed as well. 
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Alert Routines 
WARNING:  Any of these four Auto-Updates will apply to ALL alerts, regardless of filters applied 
on this screen.  Therefore, even if filtered to a certain Job Type or Store Code, and Delete All 
Alerts for All Job Costed Orders is clicked, it is going to remove all the alerts for orders that have 
been job costed, regardless of whether any are showing on the screen at the time based on the  
filters. 
 

 

Auto Update All Scheduled Quantities for All Edited RFMS Order Quantities 
 
If a line was in Order Entry and was scheduled along with a job, and then the quantity was 
changed in Order Entry by someone who had the “Create Alerts for:  Line Qty Edited” option set 
to yes, a Line Qty Edited alert will show the Order Number, Product Code, and Est. Del. Date for 
that line (in addition to other information.)  To change the quantity of the related (the line with 
the same RFMS Order Number and Line Number) line in Schedule Pro to the NEW quantity in 
Order Entry FOR ALL LINE QTY EDITED alerts simultaneously, click this button.  This will 
update all the lines it can, and for all the lines it updates, it will delete the alerts. 
 
After clicking the button, some Line Qty Edited alerts may be left:  the button will update all the 
lines that haven’t been split in Schedule Pro over several days or several trips or several crews.   
For the ones that have been split or partially scheduled, any adjustments will need to be made 
one at a time (see below). 

Auto Delete All Scheduled Jobs for all RFMS Voided Orders 
 
If an order was entered in Order Entry and was scheduled, and then it was deleted from Order 
Entry (before the Scheduled Date) by someone who had the “Create Alerts for:  Order Voided” 
option set to yes, an Order Voided alert will be created.  To delete the related job(s) from 
Schedule Pro FOR ALL ORDER VOIDED alerts simultaneously, click this button.   

Auto Delete All Related Scheduled Lines for All Deleted RFMS Order Lines 
 
If a line was in Order Entry and was scheduled along with a job, and then it was deleted from 
Order Entry by someone who had the “Create Alerts for:  Line Deleted” option set to yes, a Line 
Deleted alert will show the Order Number, Product Code, and Est. Del. Date for that line (in 
addition to other information.)  To delete the related (the line with the same RFMS Order 
Number and Line Number) line from Schedule Pro FOR ALL LINE DELETED alerts 
simultaneously, click this button.   

Delete All Alerts for All Job Costed Orders 
 
This button does exactly what it says.  If there are leftover To Be Scheduled or Line Added 
alerts, for example, that were never used or deleted.  If the job has been Job Costed in Order 
Entry, it is assumed for the normal user of RFMS that that job has been completed, billed, and 
completely closed in RFMS.  Therefore, adding or editing the job in Schedule Pro is not 
necessary. With that in mind, click the button from time to time to clear out all “obsolete” alerts.  
This will also remove the related red icons from Order Entry. 
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Alert & Tracking Note Functions  

 
Highlight an Alert or Tracking Note  
 
Insert: only a tracking note can be added, alerts are automatically added from the system 
depending on the settings in Utilities>System Options>Order Entry>Alerts>Display Schedule 
Pro Alerts on Order Entry Browse 
 
Edit:  
 
Delete or Delete Tagged:  
 
Tagging:  
 
Search  
 
Reset:  
 
VIEW RFMS ORDER: 
 

 
VIEW RELATED JOBS:  Then hit “View Related Scheduled Jobs” to see all the Scheduled jobs 
related to that alert’s Order Number (in a filtered View Scheduled Jobs screen).  If there are 
multiple jobs related to this Order, for example, a tile job and a carpet job, you can highlight 
them in the top box and preview their lines in the bottom box of this screen to determine which 
is which and decide what job to edit. 
 
ADD TAGGED “LINE ADDED ALERTS” TO EXISITING JOB:   This button allows the user to 
tag Line Added types and add those lines to the existing job.  This also allows you to remove 
the alert once the line is added. 
 
SCHEDULE JOB FOR THIS ORDER NUMBER:  This button allows the user to schedule jobs 
that are in the To Be Scheduled type.  Once it is clicked it takes the user to the Schedule New 
Job screen.  Once the job is scheduled the To Be Scheduled alert is deleted. 
 
 
OPEN THE CORRECT JOB:  Find the Scheduled job that relates to this alert (there will often 
only be one job showing in this screen), and double-click on it to open in the Edit & Complete 
screen.  
 
PULL UP THE ORDER LINES:  Hit the F8 button next to the Order Number to pull up the Order 
Entry lines and see which lines have been scheduled and which haven’t (the lines with the 
Schedule Pro icon on the left HAVE been scheduled) and to compare the Total quantities of the 
lines in Order Entry v. the Scheduled Quantities of the lines. 
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NOTE:  In this example, Lines 1, 3, and 6 have been scheduled.  They are Carpet, Pad 
(Cushion), and Carpet Labor.  It looks like 100 SY was scheduled, however, and 129 yards (and 
a little less for Pad (Cushion)) is in the Order Entry module.  You can either (a) tag the lines and 
hit “Send Tagged Lines to Scheduled Job” to add the remaining quantity to the scheduled job in 
new lines.  OR (b) you can exit this pop-up screen, delete the original lines, then pop back in 
(using the Order Number F8,) and tag and add the lines again now with the new quantity.  Or (c) 
you can make a note of the new quantity, then go back to the Edit and Complete screen and 
manually edit the line quantities to the new amounts.  After you manually edit, you can always 
pop back into the Order Number F8 screen to be sure the Total quantities and Scheduled 
quantities match. 

 
While in the Edit & Complete screen Delete lines from the Scheduled job, edit line quantities, 
and Add lines to jobs (by using the Order Number F8 button, tagging lines, and hitting “Sent 
Tagged Lines to Scheduled Job”) as needed.  Once you’re done editing, change the Reason for 
Edit, and hit OK.  Then exit from the View Scheduled Jobs screen to return to alerts.   
 

Record Details/Print Report  

 
 
A listing of the filtered alerts can be printed. Use the Print Report for Filtered 
Records button on the bottom of the screen.  
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Tracking Notes 

 
Figure: Tracking Note Screen 

 
Tracking notes can be added any time, with or without an Order Number related.  They are for 
schedulers to make notes for themselves to follow up on jobs that may not even be on the 
schedule yet.  To add, click the Insert button on the Alerts screen.  Then fill in the Order 
Number (if applicable,) Action, next action, and a note if needed, then click “OK” to save.  Later, 
a list of these can be printed (see below.) 
 
If, in the Edit & Complete screen, a job is put on Hold, or a job is cancelled without being 
deleted, it will bring this screen up and prompt for a tracking note to be entered. This is meant to 
be used when a job is postponed with no new date set.  The tracking notes are used as 
reminders to follow up on the job after a certain amount of time has passed.  Keep in mind, a 
“reminder” does not pop-up, and the Tracking Notes must be checked, whether on this screen 
or in report format, to be helpful. 

Alert & Tracking Notes Report  
Click the print report for filtered records button.  
This report will print alerts just as they are filtered in the RFMS Order Entry Alerts & Tracking 
Notes screen.  If filtered to only show “Tracking Notes” a listing of tracking notes can be printed, 
for follow up actions.  On the other hand, a certain Salesperson can be filtered to give them a 
list of To Be Scheduled alerts to verify.  The format looks like this:   
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Create Provider Records 

Schedule Pro>File>Create Providers Records 

 

Before beginning to use this section of Schedule Pro check the settings in >Utilities>System 
Options>Schedule Pro>Providers. The information sent is customized in those settings. Click 
here for details.  
 
Schedule Pro integrates with Order Entry when entering a provider record to keep the pay 
status associated with installers or suppliers in the RFMS application.  
 
Jobs listed here are determined first by the default settings in >Utilities>System 
Options>Schedule Pro>Providers Category Default Filters. 
 
 Use the find button to locate other jobs.  To go back to the default settings while still in the 

screen, use the reset button.  The clear filter button   will set the find to include all records.  
The remark type was added to the options for finding scheduled jobs in, Scheduled Jobs, Quick 
Schedule, Quick Edit, Weekly Grid and Create Providers. Only scheduled jobs with the selected 
remark type will be found.  Remarks can be added to scheduled jobs in Client Management or 

via the Client Management Remote Actions Button  while in Schedule Pro.  (Version 11.1)  
  
Let’s also say Joe Installer is marked with a pay status of Do Not Pay in Human Resources. If a 
provider record is added in Schedule Pro, this status will be inherited in Order Entry for this 
customer order.  
 
Schedule Pro has also been updated to work with ERRM. When Schedule Pro posts an installer 
record to Order Entry, then the appropriate journal entries will be made if ERRM is turned on. 

Creating Provider Records 
Schedule Pro>File>Create Providers Records 

 

 
This screen is where the provider information from schedule pro to the provider’s record in 
RFMS Core is tagged and sent. The only lines listed here will be service lines or temporary 
lines. Provider records can also be created from the Quick Edit Screen.  
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Use the find button to list the records to be created and then tag the records to create.  The 
ability to search by multiple job types for finding scheduled jobs was added in Create 
Providers Records in version 11.1. After running the update, the system will default to having 

all job types tagged.  Click the Find button . Click F8 at job types. Tag job types to be 
included.  This list is sticky (will remain until changed manually).   
 
 
Click the Create Provider… button to actually post these records to RFMS Core. 

Use Override Rate 
When creating provider records, check the use override rate box, and then click in the rate 
field and type in the new rate to use. This is the rate which will be used to create the provider 
record regardless of other system settings, the order line costs, provider type, provider rates 
and load costs.  Once the use override rate box is checked another box, Ignore Override 
Rates = 0 displays. Checking this box allows using the feature to use the “Cost” from the Order 
Line for the rate to pay the provider.  

Provider records sent over from Schedule Pro can be edited once they are in Order Entry just 
like any other provider records.   
 

 
 

Subcontractor & Non-Hourly Employee Installer Provider Record: 
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Name:  This comes from the “RFMS Associated Supplier / Installer” of the Crew that was 
assigned to the job in Schedule Pro.   

◼ If the Name is blank, first be sure there was a crew assigned to the job.   
 
◼ If there was a Crew, go to Setup / Crews and look up that Crew’s record.  Be sure 

the “RFMS Associated Supplier / Installer” is populated.  This should either pull in 
from Human Resources / Worker Information file, or less commonly, from the 
Supplier file in RFMS.   

 
Worker #:  This comes from the “RFMS Associated Supplier / Installer” of the Crew that was 
assigned to the job in Schedule Pro.  If it is blank, that probably means Worker numbers are not 
used in the HR module.  Otherwise, it would be blank for the same reasons as the Name – see 
above. 
 
Pay Type:  This comes from the “RFMS Associated Supplier / Installer” of the Crew that was 
assigned to the job in Schedule Pro.  If it is “Subcontractor,” the install quantities of the job will 
pull over from Schedule Pro.  If it is “Hourly,” there will be a place below to manually fill in the 
number of hours for which to pay the crew. 
 
Invoice Number:  This is the Order Number of the job and the order in Order Entry. 
 
Order Date:  This is the date the order was entered, and pulls from Order Entry. 
 
Delivery Date:  This is the date that the line was set to “Delivered,” and comes from Order 
Entry, usually during the Job Costing process. 
 
Installation Date:  This date pulls from Schedule Pro, and is, by default, the scheduled date of 
the job.   
For multiple day jobs, if the setting in in >Utilities>System Options>Schedule Pro>Providers 
Combine Split Lines & Display on Last Install Date is set to yes, this will be the last date of any 
multiple day jobs.  If this is not checked, usually there will be a record created for each day of 
installation for each labor line. 

If the Utilities in >Utilities>System Options>Schedule Pro>Providers>Use Units and Dates from  
is set to “Actual,” rather than scheduled, which is NOT RECOMMENDED, it will pull the date 
from the field in the Schedule Pro Job Line that is labeled “Actual Date.”  Less than 1% of 
Schedule Pro users use this setting.  It is meant to track the Scheduled Date v. the Actual Date 
of install, but most users prefer to just change the schedule if there is a date change. 

Worker Order Number:  Based on the setting in >Utilities>System Options>Schedule 
Pro>Providers>Provider Work Order Number Field, this can: 

◼ Be left blank 
 
◼ Show the Order Number of the job and the order in Order Entry (same as Invoice 

Number) 
◼ Show the first 8 characters of the Service Description from the labor line, i.e. “CPT 

INST”  
 

Product Code:  This, by default, is the Product Code of the labor line that was used to create 
the Provider Record, and pulls from Schedule Pro.  If the, in >Utilities>System 
Options>Schedule Pro>Providers>Automatically Set Product Code to 00 switch is set to Never, 
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it will be “00” – this feature is used very rarely, and is meant to help people who pay labor out of 
Accounts Payable rather than Human Resources. 

 

Service:   This is the Service Description from the labor line. 
   
Service #:   This is the Service Number from the labor line. 
 
Service:   This is the Service Description from the labor line, and pulls from Schedule Pro. 
 
Rate:  (Subcontractor & Non-Hourly Employee Only) this is the Gross Cost from the Order Entry 
line.  If the, in >Utilities>System Options>Schedule Pro>Providers>Automatically Set Rate to 0 
switch is set to Never, it will pull the Gross Cost from the associated labor line.   

 

◼ If this switch is set to “Subcontractor ONLY,” for Crews marked Subcontractor in the 
Human Resources > Worker Information file, the rate will be “0” when the record is 
first created.  This will be edited manually.  This setting is meant for companies who 
pay various installers different rates for the same service item. 

 
◼ If this switch is set to “Always,” the rate will always be “0” when the record is first 

created.  This will be edited manually later on.   
 
Total Units:  (Subcontractor & Non-Hourly Employee Only) this is the number of SF, SY, EA, or 
other units of installation on the labor line in Schedule Pro that was sent to provider records.   
 
Miscellaneous Earnings:  This will always be blank when the provider record is created, but 
can be used to make manual adjustments, both positive and negative. 
 

Total Earnings:  This is the Rate x Units + Miscellaneous Earnings. 
 

Some additional fields for Hourly Installer Provider Record: 
 

 
 

Rate:  (Hourly Only) this is the hourly rate of the Crew’s RFMS Associated Supplier/Installer 
Record.  For installers, this is set up in the Human Resources / Worker Information file. 
 

All other Hours & Earnings fields:  must be populated manually after the Provider Record has 
been sent over. 
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Reports 
Schedule Pro>File>Reports 
 

Daily Scheduling Reports  

Job Summary Reports 

Weekly Scheduling Reports 

Crew Information Reports  

Total and Analysis Report 

 
Thousands of report configurations are available in Schedule Pro, based on the various filters, 
sorts, and page breaks definable in the Reports screen.   
 

 

Schedule Pro Reports and Order Entry Field Mapping 
If the Customer Name is set up in Order Entry Field Mapping as “First Name, Last Name”, then the 
F8 button on Schedule Pro Reports will not return any results when you pick a customer from 
the customer file.  The Customer Name will need to be manually entered or use the % sign in 
the search. 
 

General Report Features 

Preview  

  Click the button to preview the selected reports one at a time.  

Output to CSV 

 
Check this box to send the selected report(s) to a .csv file for each report. Only those reports 
listed in teal will export to a .csv file.  The default location of this file is determined in set up. With 
this box is checked, when the Print button is clicked, a dialog box will display to confirm or 
change the .csv file location and name.  

 
 
 If a hard copy of the report is not needed, then choose preview and click the red x to not print.  

Print   
This selection sends the report to the chosen printer.  

Preview  
Use the preview option to verify the report or data.  

https://rfmsinc.zendesk.com/hc/en-us/articles/219368948
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The information on the bottom of the report is set in System Settings.  

 
 

Define Filters 
Jobs listed here are determined first by the default settings in Utilities>System 
Options>Schedule Pro> General>Category Default Filter Settings. Use the find button to locate 

other jobs.  To go back to the default settings while still in the screen, use the reset button.  

The clear filter button   will set the find to include all records.  
 

If a filter is applied here, any reports will only include the records within that filtered range. This 

is indicated by the button being blue.  So, if data is missing on a report, be sure to check 
the filter settings.  
 
The report header will show the filters selected on the top of the report.  

 
 

 

Print for Install Date(s) 

• The default option is based on Utilities>System Options>Schedule Pro> General>Date 
Filter 

• Specific: A single day:  this defaults to “today.” 

• Date Range:  this defaults to “today” to two weeks later. Enter or select different Start 
and End dates if desired. To include all set Start Date to 01/01/80 and End Date to 
12/31/79 
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Sort By  
This field is set to a default based in system options.    
 
This sets up a sort for any reports printed (with a few exceptions, like Crew Names & Contacts, 
that have their own sort hardcoded).  Options include: Order Number, Customer, Crew, Ship to 
Name, Stop, or “Job Number”, which is a user defined field in RFMS, and may be called “Side 
mark,” “Job / Lot,” “Add’l Info” or something else.  
 

 

Report Parameters and Options 
After setting the top filters (above), select the additional options to include for the type of report, 
then “check” the box for the report or reports. Multiple reports can be printed at the same time. 
Then click “Preview” or “Print.” Some of the additional printing options available within the 
Report Parameter and options boxes are as follows: 

Page Break  
This will be applicable for all reports in the same box.  The user can specify how the report will 
print by selecting whether to Page Break, and, if so, to use Store, Depot, Job Type, Crew, 
Customer or Salesperson. 

Include Scheduler Job Notes 
Checking this box will make sure any Scheduler Job Notes (added to the job header in 
Schedule Pro) will print on the report, just below that job. 

 
 

Include Crew Contacts 
The additional information from the contact tab in crew set up would be included.  
 

 
 
Note: The landscape reports display information which is not available on portrait reports. Daily 
reports are based on lines; summary reports are based on the header.  
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Daily Scheduling Reports 
Schedule Pro>File>Reports>Daily Scheduling Reports 
 

 Report of jobs including the individual lines. First choose the lines to include from the grid.  
Deduct Capacity-as defined in system options capacity settings.  
 

 
 
Then, choose the report for the required sort by… and desired amount of information.   
 
 

  
 
 

Daily Schedule Report by  

Landscape Reports  
Because of the size, landscape reports can contain more columns of information.  These all 
have the same information they differ in how they are sorted.  

Order Number Store 
Depot 
Date & Time 

Customer 
Salesperson 
Crew 

Ship To Name 
Job Number 
Style 

Ship to Address 
Ship to City State Zip 
Color 

Job Status 
Warehouse 
Prep 
Job Type 

Stop 
Progress 
Qty 

Only the report titles written in teal 
can be outputted to a CSV format. 
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Portrait Reports 
Order Number Job Number 

Job Status 
Date & Time 

Customer 
Ship to Name 
Crew 

Ship to Address 
Ship to City State Zip 
Job Type 

Stop 
Progress 
Qty 
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Jobs Edited  
Use the drop down list to choose the time frame of the edits to see only the latest edits made. 
For example to see what changes daily run the report at the end of each day for today.  The 
jobs included on the report will still have to fall within the date parameters for the reports 
regardless of the edit dates.   
 

 
 

Material Status 
These reports are useful in listing jobs with materials which need to be ordered or have not 
been received for upcoming jobs.  
 

 
 

Filter Material Status by Supplier  
Use the F8 Key to search for and select a single supplier to limit the material status reports.  

Print for Status  
Choose either On Order- Promise Date Conflicts or On Order-All 
The status choices apply to both the material and provider reports.  
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Material Status 

 
Figure: Sample Report 

Material Status with PO Information  

 
Figure: Sample Report 

Provider Records Status 
Use the drop down list to choose between all, created or not created provider records. 

 
Figure: Sample Report 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Job Summary Reports 
Schedule Pro>File>Reports>Job Summary Reports 
Do not include the lines and print one record per job per day.  
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Only the report titles written in teal can be outputted to a CSV format. 
 
 
The choice of summary report is determined by the information desired to include.  
 

Job Summary 1-3 (Portrait)  
All include the shaded information in the first table.  Additional information included in each 
report is shaded in the table under the report number.  
 

Portrait  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 

Job Summary 1 Job Number 
 

Portrait  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 

 

 
Figure: Sample Report 

Job Summary 2 Primary Crew 

Portrait  Order Number  Customer 

Ship to name Primary Qty Job # 
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Primary Crew Ship to Address Job Status 

 

 
Figure: Sample Report 

Job Summary 3 Ship to Address/Job Status 
Portrait  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 
 

 
Figure: Sample Report 

Job Summary Detailed 1-4 
All include the shaded information in the first table.  Additional information included in each 
report is shaded in the table under the report number.  
 

Landscape  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 

 

Job Summary Detailed 1 Ship to Address/Warehouse Prep Start/End Date 
Landscape  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 

Warehouse Prep Start/End Date  

 

 
Figure: Sample Report 
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Job Summary Detailed 2 Ship To Address, Store, Depot, Warehouse Prep, Job 
Types and Start/End Date. 
Requires legal size paper. 
 

Landscape/Legal  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 

Warehouse Prep Start/End Date Store  

Depot Job Types  

 

 
Figure: Sample Report 

Job Summary Detailed 3 Primary Quantity Style, Primary Quantity Status and 
Time Slot.  
Can be exported to .csv 

Landscape  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 

Export to .csv Primary Qt Style Primary Qty Status 

Time Slot   

 
 

 
Figure: Sample Report 

 

Job Summary Detailed 4 Telephone 1, Telephone 2, Salesperson, Ship To Address, 
Primary Quantity Style, Primary Quantity Status, Time Slot and Progress 

Can be exported to .csv 
 

Landscape  Order Number  Customer 

Ship to name Primary Qty Job # 

Primary Crew Ship to Address Job Status 

Export to .csv Primary Qt Style Primary Qty Status 

Time Slot Tele 1 Tele 2 

Salesperson Progress  
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Figure: Sample Report 

Weekly Scheduling Reports 
Schedule Pro>File>Reports>Weekly Scheduling Reports 

This report lists the schedule by week for the time frame selected in filters and sorts. If the dates 
included in the Find range cover multiple weeks, multiple reports will be printed.  Use the 
dropdown arrow to select a sort and a page break.  
 

 
 

 



 

Version 19.0  118 
 

Figure: Sample Report 

 

The Weekly Scheduling Report is not able to be saved to CSV due to the format of 
the report. 

Crew Information Report 
Schedule Pro>File>Reports>Crew Information Report 

 
This report lists crews based on the selected depots.  Their contact information is included.  
 

 
 

 
Figure: Sample Report 

 

Totals and Analysis Reports 
Schedule Pro>File>Reports>Totals & Analysis Report 

  
Note that only the report is written 
in teal can be outputted to CSV. 
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Figure Totals & Analysis screen 

 
Figure: Totals & Analysis Reports Screen 

This report has the ability to print the Totals and Weekly reports based on all job lines or on 
Deduct Capacity Lines only.  In either case job lines with a Job Type of "MISCELLANEOUS" will 
not be included 

 

Tracking Table 1/Tracking Table 2 
The labels for these tables are set in System Settings..   

Full Report  
Subtotals by each value for the tracking table, gives a count and percentage with job details.  
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Figure: Sample Report 

Summary  
Subtotals by each value for the tracking table, gives a count and percentage only.  

 
Figure: Sample Report 

Date Discrepancies with Order Entry 
This is a report of jobs where the scheduled date and the order entry estimated delivery date do 
not match.  It is sorted by the estimated delivery date with those with no date listed first.  

 
Figure: Sample Report 

Totals By Salesperson 
This report gives a tally of the job types by salesperson for the parameters chosen in filters and 
sorts.  
 

 
Figure: Sample Report 

Totals by Crew 
This report was added in version 10.5.6 
This report can be printed by any selected date range.  It will print the Total Number of 
Jobs and Job Type Quantities by Crew. 
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Figure: Totals by Crew Sample Report  

Totals by Product Codes 
This report summarizes the product codes by day for the parameters chosen in filters and sorts. 

 
Figure: Sample Report 

Weekly Availability by Job Type  
This report summarizes the crew numbers available and scheduled per week for the parameters 
chosen in filters and sorts. 
 

 
Figure: Sample Report 

 

For this report, the Availability lines will only print if Page Break is set to Depot or None. 
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Weekly Quantities by Job Type  
This report summarizes the scheduled quantity scheduled versus total capacity per week for the 
parameters chosen in filters and sorts. 
 

 
Figure: Sample Report 

 

For this report, the Total Capacity lines only print if Page Break is set to Depot or None. 

 

Weekly Quantities by Crew  
This report summarizes the scheduled quantity scheduled per crew and per week for the 
parameters chosen in filters and sorts. 
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Figure: Sample Report 

 

Weekly Number of Jobs by Crew 
This series of reports summarizes the number of jobs scheduled per crew and per week for the 
parameters chosen in filters and sorts. One report per Job Type is given.  
 

 
Figure: Sample Report 
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References 

Understanding Schedule Pro 

Jobs  
A group of lines scheduled to be completed at the same time. Can be all or part of an RFMS 
customer order, claim or temporary job.  

Header  
Information about the job, some of which can be edited manually for tracking and reporting 
purposes.  Crews and Scheduled start and end dates should not be edited here.  

Lines  
Individual material and service lines which make up the job  

Crew 
An installer or group of installers who perform a job.  

Depot  
A way of grouping crews.  
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3 Ways to Schedule Jobs 
Set Alert for Order to be scheduled through a Centralized Alerting System  
 Schedule Job for Created Alert and Establish Specifics  
 

• Select Dates and Time  

• Select Tracking Information  

• Select Crew  

• Add to Calendar  
 

 Manually Schedule Order to Provide for more Focused Control  
• Select Order to be Scheduled from Calendar   

• Tag Lines to be Scheduled for Installation  

• Check Installation Availability for Selected Date  

• Select Date, Time, and Crew for Job  

• Add to Calendar  

Temporarily Schedule Order to Reserve Future Installation Dates (Soft 
Schedule)  

• Enter Job Information for Customer Without an Order Being Created  

• Create Temporary Line(s) Indicating the Job Type and Estimated Quantity  

• Associate Actual Order with Temporary Order Once Created  

• Locate Actual Order and Tag Appropriate Lines  

• “Send Over RFMS Order and Lines to Schedule Job”  

• Save Job  
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Schedule Pro Work Flow 
SCHEDULE JOB 

1- Alert Set for Requested Installation Date (Est Del Date or Line Est Del Date) 

a. Multiple Schedule Dates- Internal Notes indicate what dates for each phase 

2- Job put on schedule based on date requested,  

a. IF material line(s) from Order Entry in GEN PO status the Schedule Pro default 

status should be left as SCHEDULE REQUESTED  

3- Once or twice a day filter scheduled jobs by “Schedule Requested” Status.   

a. Review line statuses to see updated line status from Gen PO to On Order. 

b. Review the Promise Date for the material to confirm meets 2 day prior to 

installation date deadline. 

4- Contact customer to confirm the installation date desired. 

a. Review any details of installation as needed 

b.  Email client reminder of installation appointment as well as documents to review 

prior to installation (“How to prepare for your floor covering installation” etc.) 

5- Change Schedule Pro Status to SCHEDULED    

GET READY FOR INSTALL 
6- Material Status Report generated to track materials 2-3 Days prior to installation date 

7- Call customer to confirm installation 24 hours prior to installation.   

a. Discuss normal installation preparation for the type of job being installed.  

b. Review the scheduled job for any extraordinary things the client was supposed to 

perform, usually indicated with a service line indicating what is their responsibility 

(client to remove existing material or client to remove and replace furniture, etc.).  

Confirm the client has  completed the necessary work and is ready for installation 

c. Discuss balance due and review policy regarding collecting COD  

d. Make notes of the conversation in Scheduler Notes section 

8- Change status to CONFIRMED 

9- Generate Installation Job Packet 

a.  Work Order for customer sign off 

b.  Work Ticket for installer’s copy 

c. Tag jobs for Installer to generate Map. (if multiple jobs being performed during a 

day from one jobsite to the next) 

d. Print  Diagram (Open scheduled job- click on View Order- Open  attachments- 

find diagram and print) 

10- Add additional flags in Tracking Table Notes 1 (Material pick up, Material Not Ready 

etc.) 

 
SPECIAL NOTE: Additional Charges 

Additional Charges phoned in throughout the day should be added to the schedule and a 
Work Ticket generated in advance to check the installer back in with a document that has 
already been prepared. 
 



 

Version 19.0  127 
 

DISPATCH CREWS 
11- Print Grid as a guideline to expedite loading crews 

12- Collect PREVIOUS job’s work orders, work tickets, COD’s prior to releasing NEW 

installation job packet 

a. Note material changes on Work Ticket/Pick Ticket  

b. Note job site changes on Work Ticket (job not ready, reschedule, inspect, etc.) 

c. Additional  Work Tickets prepared given to installer for review and sign off 

UPDATE SCHEDULE/ORDERS 
13- Collate Work Tickets/Install Bills into two categories 

a. Work Tickets-NO Changes 

b. Work Tickets- WITH Changes  

14- Go to Quick Edit to Update Statuses 

a. Change today’s jobs status to IN PROGRESS  

b. Change jobs turned in status as needed (PHASE COMPLETE, JOB 

COMPLETE, Reschedule, and Inspect etc.) 

c. Add Tracking Table Follow up as needed (Installer Bill Needed, Repair Needed, 

Change Order Pending) 

15- Providers Earnings Posted 

a. Filter by Status if required for job completion to be confirmed prior to earnings 

being posted. (Phase Complete and Job Complete) 

b. Post Earnings for Work Tickets with NO Changes 

c. Post Earnings for Work Tickets WITH Changes  

• ONLY if access to Order Entry is available to make necessary corrections  

(Since additional charges should be added while installation is still being 

performed the only changes that would be necessary would be to reduce 

qty, rate due to job site difficulties) 
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Tab Capacity Calculations 
Using Automatically Calculate based on line quantities. 

Crew Assigned 
Line item material type units / Line item material type line item crew daily quantity 
 

Crew Unassigned – same tab 
Line item material type units (a) / total depot quantity for line item material type for day (b1) / 
total depot crews for line item material type for day (b2) 
 

Crew Unassigned – different tab 
Line item material type units (a) / total depot quantity for line item material type for day (b1) / 
total depot crews for line item material type for day (b2) * total depot quantity of tab material 
type that also installs the line material type (e) / total depot quantity of tab material type for the 
day (f) 
 

Qty Assigned 
Line item material type units / Line item crew line item material type daily quantity * line item 
crew tab material type daily quantity 
 

Qty Unassigned 
a/b1/b2 * c/d * e/f 
 
a = line item units 
b1 = total quantity for line item material type for depot 
b2 = total number of crews for line item material type for depot 
 
c = total depot quantity for tab material type for day 
d = total depot crews for tab material type for day 
 
e = total depot quantity of tab material type that also installs the line material type 
f = total depot quantity of tab material type for the day 
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FAQ 
Can I have people in just to look at the schedule? 
 
Yes, Read-Only users do not count toward the Schedule Pro user count.  That count is only for 
active simultaneous users. Opening Schedule Pro in Read Only Mode from Order Entry - will open 

View Schedule Jobs and display related jobs if scheduled jobs exist. Click here for details. 

 
 
Is it possible to condense the grid down to fit more jobs on the screen? 
 
Yes, it is!  The “simple” grid view allows the users to see the grid with one line per job, rather 
than five.  This grid also has a few enhanced features, such as a “Right Click” menu to edit jobs 
or view more information, and a Search feature. Click here for details. 
 
If a job is split over multiple days, does a provider records for each day of the job need to 
be added? 
 
No!  Go to Utilities>System Options>Schedule Pro>Providers> Combine Split Lines Display on 
Last Install Date and set it to yes.  Also, the “Work Ticket” in schedule pro can now do the 
reverse, and combine split lines all on the first day of the job, using a checkbox in the Print 
Preview menu. 

 
Is it possible to just schedule from the grid? 
 
To some degree; go to the grid, and select a Date and a Crew, and click in the corresponding 
box, then click the insert button to add a job, that Date & Crew will be pulled up in the Schedule 
New Jobs screen.  Now, add the job, tag lines, choose a time slot, and click “Add” to schedule. 
 
How can the number of days on a job be changed? 
 
It is not a good idea just to change the “End Date” of the job.  This doesn’t affect the actual line 
quantities, thus it doesn’t affect the “Deducting of capacities” from crews or depots.   It is best to 
use the "Split Lines" tool to add more days to a job, or reduce the number of days on a 
job.  First, schedule a job initially for the number of days to allow using the Number of Days field 
on the Schedule New Jobs screen. 
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How can a job be split between multiple crews? 
 
This is very similar to the “changing of number of days” described above.  First, schedule the 
job.  Then, double-click the job to open in the “Edit & Complete” screen.  Then, click the “Split 
Lines” tool.  (NOTE:  If a “Secondary Crew” is added without splitting the lines, it will not show 
on the grid or many of the reports for that secondary crew.) 
 
In the Split Lines screen, up to 10 total crews can be added, and assign a percentage of the 
overall quantity of the job to each.  The percentages must add up to 100.   
 

 
Then, click “Apply Split” to affect the change, and save the job as normal. 
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How can the material status for upcoming jobs be checked?   
 
Print the Material Status report, using the settings here: 

 
 

How much work can be done? 
 
By Crew:  
 
On the crew set up screen, enter the amount of each job type a crew can do in one day.  This is 
helpful when scheduling to know if a job will take a crew a single or multiple days.  
 

 
 
Where can I find this information? 
 
On the Select Crew to Schedule Screen, there are several indicators of a crew’s availability.  

1. The dot next to their name.  
2. The amounts in the crew capacity levels section. 
3. The details of these capacity levels scheduled are found in the Job lines scheduled 

section.  
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4. The system can be set to give warnings when crews are overbooked.   
  

  
 
The indicator dots can also be seen on the weekly grid.  
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Figure: Crew Capacity Related Warnings 

 

 
By Depot:  
 
Each crew is assigned to a depot. The daily quantities for all the crews add up the depot 
capacity.  Depot capacities are helpful in determining if outside crews might be needed or to 
advise the sales staff that installation times may be further out than normally expected.   Look at 
trends to see if crews need to be redistributed between depots.  
 
Where can I find this information? 
 
The percentage of depot availability by Job Type is shown on the calendar portion of the 
Schedule New Job Screen.  Click on the depot name at the bottom to switch between depots.  
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Trouble Shooting 
Provider records are not being created. 

➢ Is the crew marked inactive in Human Resources or Accounts Payable>Suppliers?  

Lines on the job are not showing up in schedule pro. 
➢ Has the product code been associated with a job type? Click here for details. 

The ending date was changed in schedule pro, but it still shows on only one day. 
➢ The dates must be split on the lines not on the header of the job.  

A secondary crew was added in schedule pro, but it still shows scheduled to one 
crew. 

➢ The job must be split between crews on the lines not on the header of the job.  

Completed jobs are not showing on the Create Provider Screen.  
➢ Have service lines been completed?  
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Internal Warning Messages 

Message Description Level when 
scheduling new 
job 

Level when 
editing existing 

Customer Name or 
Order Must be 
selected 

An existing customer 
order or customer name 
must be added to each 
job 

Restrict Restrict 

Line(existing or 
temporary) must be 
present 

a line on a customer 
order must be tagged or 
a temporary line must be 
entered 

Restrict NA 

Appropriate Dates  The scheduled dates 
must be logical 

Restrict Restrict 

Multiple Day % must 
add up to 100 %  

Total for all days must 
equal 100% 

Restrict NA 

Crew Installs all job 
types 

When assigning a crew 
to a job, the crew must 
be setup to install the job 
type of the line items 

Restrict Restrict 

RFMS line item unit 
type conflicts with job 
type unit type 

The unit of measure on 
the customer order line is 
compared with the unit of 
measure selected when 
setting up the job types.  

Restrict  
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	Is it possible to condense the grid down to fit more jobs on the screen?
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